Increase queue size


#1

Since I often get: org.elasticsearch.common.util.concurrent.EsRejectedExecutionException: rejected execution (queue capacity 1000) on org.elasticsearch.search.action.SearchServiceTransportAction$23@644df44e

and warnings in kibana, I would like to increase the queue size. I am reading the documentation https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-threadpool.html since it is referred to everywhere I read about this. But that documentation does not really tell me where to configure this and how. Is it in the configuration file? And is multiline syntax ok in the configuration-file, like:

threadpool:
    index:
        type: fixed
        size: 30
        queue_size: 1000

?
Thanks.


(Magnus B├Ąck) #2

This goes into elasticsearch.yml or as a dynamic setting that you post via REST (the latter is obviously easier to change since you won't have to bounce each node). The syntax in your example is fine.

Your thread pools are exhausted because your cluster is underpowered for its load. Increasing the queue size should result in more queries completing but won't help with your presumably really bad response times.


#3

Hi Magnus.

Thank you for your reply.

I don't get bad response-times and this error only occurs when I load a kibana dashboard with 18 visualisations.


(system) #4