Increasing ‘index.mapping.nested_objects.limit’ setting

I have the same problem as this Increasing 'index.mapping.nested_objects.limit' setting's value has no effect.

The new setting, although applied to the index, doesn't seem to have any effect on existing fields. Is this supposed to work this way(not being applied to existing fields)?