Increasing limit of total_fields in a index?


(Patlola) #1

https://www.elastic.co/guide/en/elasticsearch/reference/current/mapping.html#mapping-limit-settings

after setting
index.mapping.total_fields.limit: 2000 in elasticsearch.yml and restarting elasticsearch is not starting, it's automatically shuttingdown.


(Nik Everett) #2

Is it logging anything?


(Patlola) #3

nope


(Patlola) #4

@nik9000 found the issue, thanks
Since elasticsearch 5.x index level settings can NOT be set on the nodes
configuration like the elasticsearch.yaml, in system properties or command line
arguments.In order to upgrade all indices the settings must be updated via the
/${index}/_settings API. Unless all settings are dynamic all indices must be closed
in order to apply the upgradeIndices created in the future should use index templates
to set default values.
so updated using api


(Nik Everett) #5

It really should log something about that setting being invalid then....


(Patlola) #6

yes, it was logging.
i wasn't checking the correct logs
thanks for the concern :slight_smile:


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.