Increasing number of open files descriptors in elastic search

I am increasing the number of open files descriptors for the root user by
adding the following entry in /etc/sysctl.conf

fs.file-max = 751864

However when I am restarting elastic search as root user then elastic
search is starting with

max_file_descriptors value as 4096

Why the above change is not visible to elastic search?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2393716f-1571-4b64-9572-9984ceef76b2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

When the elasticsearch instance restarted, how do you check? Did you check
using this command cat /proc//limits ?

Jason

On Wed, Nov 26, 2014 at 6:09 PM, Vijay Tiwary vijaykr.tiwary@gmail.com
wrote:

I am increasing the number of open files descriptors for the root user by
adding the following entry in /etc/sysctl.conf

fs.file-max = 751864

However when I am restarting elastic search as root user then elastic
search is starting with

max_file_descriptors value as 4096

Why the above change is not visible to elastic search?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2393716f-1571-4b64-9572-9984ceef76b2%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2393716f-1571-4b64-9572-9984ceef76b2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAHO4itzKNAa-fmXjrxf0CaL2PLCc26kwszPyKOSRwRuSsXLT2w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Yes. By Using the same command the max open files count is 4096

On Wednesday, November 26, 2014 6:30:02 PM UTC+5:30, Jason Wee wrote:

When the elasticsearch instance restarted, how do you check? Did you check
using this command cat /proc//limits ?

Jason

On Wed, Nov 26, 2014 at 6:09 PM, Vijay Tiwary <vijaykr...@gmail.com
<javascript:>> wrote:

I am increasing the number of open files descriptors for the root user by
adding the following entry in /etc/sysctl.conf

fs.file-max = 751864

However when I am restarting elastic search as root user then elastic
search is starting with

max_file_descriptors value as 4096

Why the above change is not visible to elastic search?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2393716f-1571-4b64-9572-9984ceef76b2%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2393716f-1571-4b64-9572-9984ceef76b2%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/9103aabf-a7f6-4ca9-8624-d7781ec3f757%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.