Index lifecycle error

Hi all. We have elastic cloud 7.12
I am getting the following errors on the lifecycle for all the new policy I ve put in place.

Any idea?

illegal_argument_exception: setting [index.lifecycle.rollover_alias] for index [gitlab-prod-metricbeat-7.10.2-2021.04.24] is empty or not defined

Here is the policy:

{
  "gitlab-policy" : {
    "version" : 1,
    "modified_date" : "2021-04-13T09:35:32.429Z",
    "policy" : {
      "phases" : {
        "hot" : {
          "min_age" : "0ms",
          "actions" : {
            "rollover" : {
              "max_age" : "30d"
            },
            "set_priority" : {
              "priority" : 100
            }
          }
        },
        "delete" : {
          "min_age" : "0d",
          "actions" : {
            "delete" : {
              "delete_searchable_snapshot" : true
            }
          }
        }
      }
    }
  }
}

Cheers

Hi all.
anyone on this issue?

Cheers

From https://www.elastic.co/guide/en/elasticsearch/reference/7.12/ilm-rollover.html;

  • The index.lifecycle.rollover_alias must be configured as the alias to roll over.

We do try to get to topics when we can, but there's no SLAs here, it's all best efforts.
If you'd like guaranteed response times then we can get you in contact with someone that can discuss that with you :slight_smile:

Hi mark.
I didn't say anything and I appreciate your effort.
We are already Elastic customer but I don't get this level of support cause you need an higher level of investment which is not what we have right now.
In the past I had no answer for some post and I'm totally fine.

Cheers mate

/Alf

Hi all.
I am still getting the same error in some indices....
illegal_argument_exception: setting [index.lifecycle.rollover_alias] for index [mydata-7.10.2-2021.05.05] is empty or not defined

I changed a few indices settings adding
e.g index.lifecycle.rollover_alias: "mydata"

but now I got
illegal_argument_exception: index.lifecycle.rollover_alias [mydata] does not point to index [mydata-l7.10.2-2021.05.07]

What am I doing wrong?

Also how can I fix that through my filebeat helm config?

cloud.id: "{cid}" cloud.auth: "{cau}"
setup.ilm.enabled: false
setup.template.name: "{app}" setup.template.pattern: "{app}-metricbeat-{env}-*" setup.dashboards.index: "{app}-metricbeat-{env}-*" [setup.kibana.space.id](http://setup.kibana.space.id): "{app}"

output.elasticsearch:
index: "{app}-metricbeat-{env}-%%{[agent.version]}-%%{+yyyy.MM.dd}"

Cheers

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.