Index Lifecycle Policy getting assigned even after ILM is turned off

I created an ILP and was able to succesfully add it. I no longer need the ILP so what I did is:

  1. removed the ILP from the index (POST index/_ilm/remove)
  2. turned off ILM (POST _ilm/stop)
  3. deleted the ILP completely

I have restarted the nodes since then, however, newly created indices are still getting assigned with the ILP. I have confirmed that the ILM is turned off and that the ILP no longer exist (GET _ilm/policy).

Why is it still getting assigned? How do I remove the ILP completely? How do I stop the ILP from getting assigned to the new indices?


Hi VeeT,

It sounds like you have a template configured to automatically set the setting on newly created indices. If you check your templates (GET /_template) you should be able to see for sure.

Hi dakrone. Ah, yes. I still have the template. So once I delete the template, then it shouldn't be applied anymore, correct?

Yep, you can either delete it or change it not to include the setting.

Thanks Lee

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.