Index.ttl.disable_purge flag not working?


(Stefan Pi) #1

Hi everybody,

I'm using ES 0.19.4. I tried to disable the deletion process for documents
of an existing index that was initially created with a TTL (The TTL
deletion is working fine). I've tried to update the index using the
index.ttl.disable_purge flag as described here:
http://www.elasticsearch.org/guide/reference/api/admin-indices-update-settings.html
but it seems not to work:

curl -XPUT '://_settings' -d '{"index" :
{"index.ttl.disable_purge" : true} }'

This was written to the log file of the node after doing the above call:

[WARN ][cluster.metadata ] [] [] ignoring non dynamic index
level settings for open indices: [index.index.ttl.disable_purge]

I also tried the call with a slight flag name variation removing the
"index" at the beginning of the flag:

curl -XPUT '://_settings' -d '{"index" :
{"ttl.disable_purge" : true} }'

but also without success:

[WARN ][cluster.metadata ] [] [] ignoring non dynamic index
level settings for open indices: [index.ttl.disable_purge]

I understand that non-dynamic settings can not be changed when the index
was already created but according to the documentaton (above link) this
should be a dynamic setting. Am I doing something wrong? Any help would be
much appreciated!

Thanks,
Stefan


(Benjamin Devèze) #2

You are right it is a bug, expect it to be fixed tonight.

Thanks

On Tue, Jun 12, 2012 at 1:52 PM, Stefan Pi sp@media-metrics.de wrote:

Hi everybody,

I'm using ES 0.19.4. I tried to disable the deletion process for documents
of an existing index that was initially created with a TTL (The TTL deletion
is working fine). I've tried to update the index using the
index.ttl.disable_purge flag as described here:
http://www.elasticsearch.org/guide/reference/api/admin-indices-update-settings.html
but it seems not to work:

curl -XPUT '://_settings' -d '{"index" :
{"index.ttl.disable_purge" : true} }'

This was written to the log file of the node after doing the above call:

[WARN ][cluster.metadata ] [] [] ignoring non dynamic index
level settings for open indices: [index.index.ttl.disable_purge]

I also tried the call with a slight flag name variation removing the "index"
at the beginning of the flag:

curl -XPUT '://_settings' -d '{"index" :
{"ttl.disable_purge" : true} }'

but also without success:

[WARN ][cluster.metadata ] [] [] ignoring non dynamic index
level settings for open indices: [index.ttl.disable_purge]

I understand that non-dynamic settings can not be changed when the index was
already created but according to the documentaton (above link) this should
be a dynamic setting. Am I doing something wrong? Any help would be much
appreciated!

Thanks,
Stefan

--
Benjamin DEVEZE


(Stefan Pi) #3

Great! Where will it be fixed? Do I have to download and build the master
or will it be patched into 0.19.4?

Thanks, Stefan


(Benjamin Devèze) #4

Ok it has been fixed in 0.19 branch and master. So you can use the
master or wait for 0.19.5 I guess.

On Tue, Jun 12, 2012 at 4:21 PM, Stefan Pi sp@media-metrics.de wrote:

Great! Where will it be fixed? Do I have to download and build the master or
will it be patched into 0.19.4?

Thanks, Stefan

--
Benjamin DEVEZE


(Stefan Pi) #5

Thank you very much!


(system) #6