Index with geo_point entry doe not show up in Maps/Heatmap

I'm importing some old apache logs through logstash to ES, and one step is converting the ip address to coordinates.

Originally I did not update the index template of logstash to use geo_point for the coordinates-field so I deleted the index and started the import from beginning.

The index now seems to properly recognise tieh coordinates-field as a geo_point when inspecting the mappings:

        "coordinates": {
          "type": "geo_point",
          "ignore_malformed": false,
          "ignore_z_value": true
        },

However when I go over to Kibana / Maps / Create map / Add layer / Heat map, the dropdown does not list the logstash index. If I manually type logstash in the index pattern text box, I get " logstash doesn't match any options".

Why doesn't the heat map creation identify the index which has geo_point entries?

Found the problem.

I had at one point created a Management / Stack Management / Kibana / Index Patterns from the old index file which had the old field definitions.

Duh...

So for the sake of completeness, the solution was to remove the old index pattern, and replace it with a new one derived from the corrected index.

1 Like

Thanks for updating with your solution!