Ingest-user-agent Plugin

I updated the elasticsearch trought yum to 6.2.3. After the update the elasticsearch did not start after investigating the logfile i found out that plugins are not compatible.

As described in the documentation i tried to remove the plugins and reinstall them.

bin/elasticsearch-plugin install ingest-user-agent -v
Checking if url exists:
Exception in thread "main" Connection timed out (Connection timed out)

Also when i try to open the above link in a browser i get an xml error message
.... NoSuchKey .... it seems that the plugin for this version is missing in the official download source.

Are there other ways to install an actual plugin?



I think you are running behind a proxy most likely and that your proxy does not reach our download server. Which is causing a TimeOut error.

The way the plugin manager works, it tries different URLs. Here it fails with the first and instead of an expected 404 error, there is a time out which gives no chance to download the "right" artifact.

If you want to download it manually, look at the doc:

It says the URL is:

Thanks for your quick reply!

Yes I am behind a proxy but i did set the proxy environment variables. I downloaded the plugin trought wget and the offline installation worked fine.

It seems like the plugin manager does ignore the proxy variables. Is there an official way to download plugins over a proxy?

Yes. See

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.