Inserting query into percolator - long delay getting response


(Matt Price) #1

Hi,

Today we starting noticing that we have a long response delay from ES when
inserting a single query into a percolator.

Details:
Using ES 1.0.0
Using Java client library (transport client)
About 5 queries in this percolator

The delay is ~8 seconds long and the environment is relatively stress free.
Has anyone encountered this issue before or have any suggestions on
improving the insert time for a query?

Note that we are not seeing this behavior with bulk indexing, etc. so the
problem seems to be just confined to the percolator itself.

Thanks,
Matt

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/ec2fdb62-2535-4e80-9f74-1c70cd45994a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Matt Price) #2

Sorry a few other details:
Settings for index that holds percolator:
{
"rules" : {
"settings" : {
"index" : {
"codec" : {
"bloom" : {
"load" : "false"
}
},
"uuid" : "_Flxtpi9R8C3wiCe3O04kA",
"number_of_replicas" : "9",
"number_of_shards" : "1",
"version" : {
"created" : "1000099"
}
}
}
}
}

where we have 10 nodes serving as our data nodes

On Saturday, February 22, 2014 4:31:32 PM UTC-5, Matt Price wrote:

Hi,

Today we starting noticing that we have a long response delay from ES when
inserting a single query into a percolator.

Details:
Using ES 1.0.0
Using Java client library (transport client)
About 5 queries in this percolator

The delay is ~8 seconds long and the environment is relatively stress
free. Has anyone encountered this issue before or have any suggestions on
improving the insert time for a query?

Note that we are not seeing this behavior with bulk indexing, etc. so the
problem seems to be just confined to the percolator itself.

Thanks,
Matt

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/88af95e5-7ddf-4818-8f9f-4bfe83ff4643%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #3

Hey,

can you show mapping/setting of that index? How do you insert the data (can
you show the code)? Can you set debug log level on the elasticsearch nodes?
Does this also happen on a one node cluster (as a test)?

--Alex

On Sat, Feb 22, 2014 at 10:34 PM, Matt Price mattprice11@gmail.com wrote:

Sorry a few other details:
Settings for index that holds percolator:
{
"rules" : {
"settings" : {
"index" : {
"codec" : {
"bloom" : {
"load" : "false"
}
},
"uuid" : "_Flxtpi9R8C3wiCe3O04kA",
"number_of_replicas" : "9",
"number_of_shards" : "1",
"version" : {
"created" : "1000099"
}
}
}
}
}

where we have 10 nodes serving as our data nodes

On Saturday, February 22, 2014 4:31:32 PM UTC-5, Matt Price wrote:

Hi,

Today we starting noticing that we have a long response delay from ES
when inserting a single query into a percolator.

Details:
Using ES 1.0.0
Using Java client library (transport client)
About 5 queries in this percolator

The delay is ~8 seconds long and the environment is relatively stress
free. Has anyone encountered this issue before or have any suggestions on
improving the insert time for a query?

Note that we are not seeing this behavior with bulk indexing, etc. so the
problem seems to be just confined to the percolator itself.

Thanks,
Matt

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/88af95e5-7ddf-4818-8f9f-4bfe83ff4643%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM8GJBOi0Py7u%2BNys9KXGTix_hN5rJzHt%2B1zs%3Dj2v0qcjw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4