Insserv-compat required on openSUSE Leap 15


(David Randall) #1

After installing several beats, they failed to start with the following.

# systemctl enable packetbeat.service
Synchronizing state of packetbeat.service with SysV service script with /usr/lib/systemd/systemd-sysv-install.
Executing: /usr/lib/systemd/systemd-sysv-install enable packetbeat
/sbin/insserv: No such file or directory

This is a minimal server install of openSUSE Leap 15. Installing the insserv-compat package resolves the issue. Is it possible to add this as a requirement to the beat rpms? This affects all beats. I didn't see this problem on openSUSE Leap 42.3 with a server install.

auditbeat version 6.3.0 (amd64), libbeat 6.3.0 [a04cb664d5fbd4b1aab485d1766f3979c138fd38 built 2018-06-11 22:49:45 +0000 UTC]
filebeat version 6.3.0 (amd64), libbeat 6.3.0 [a04cb664d5fbd4b1aab485d1766f3979c138fd38 built 2018-06-11 22:34:44 +0000 UTC]
heartbeat version 6.3.0 (amd64), libbeat 6.3.0 [a04cb664d5fbd4b1aab485d1766f3979c138fd38 built 2018-06-11 22:46:23 +0000 UTC]
metricbeat version 6.3.0 (amd64), libbeat 6.3.0 [a04cb664d5fbd4b1aab485d1766f3979c138fd38 built 2018-06-11 22:40:21 +0000 UTC]
packetbeat version 6.3.0 (amd64), libbeat 6.3.0 [a04cb664d5fbd4b1aab485d1766f3979c138fd38 built 2018-06-11 22:30:57 +0000 UTC]

cat /etc/os-release

NAME="openSUSE Leap"
VERSION="15.0"
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.0"
PRETTY_NAME="openSUSE Leap 15.0"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.0"
BUG_REPORT_URL="https://bugs.opensuse.org"

uname -a

Linux lxd3 4.12.14-lp150.12.4-default #1 SMP Tue May 22 05:17:22 UTC 2018 (66b2eda) x86_64 x86_64 x86_64 GNU/Linux

zypper search -si beat

Loading repository data...
Reading installed packages...

S  | Name              | Type    | Version | Arch   | Repository   
---+-------------------+---------+---------+--------+--------------
i+ | auditbeat         | package | 6.3.0-1 | x86_64 | elasticsearch
i+ | filebeat          | package | 6.3.0-1 | x86_64 | elasticsearch
i+ | heartbeat-elastic | package | 6.3.0-1 | x86_64 | elasticsearch
i+ | metricbeat        | package | 6.3.0-1 | x86_64 | elasticsearch
i+ | packetbeat        | package | 6.3.0-1 | x86_64 | elasticsearch

zypper search -s insserv-compat

Loading repository data...
Reading installed packages...

S | Name           | Type    | Version       | Arch   | Repository            
--+----------------+---------+---------------+--------+-----------------------
  | insserv-compat | package | 0.1-lp150.2.1 | noarch | openSUSE-Leap-15.0-Oss

Let me know if you need any other information. Thanks for the great software!


(Andrew Kroh) #2

From https://software.opensuse.org/package/insserv-compat (I had to research what the pkg provided)

insserv is used enable System V init scripts. This package only contains a stub implemenation for use on systemd only systems.

insserv isn't something that Beats are using anywhere so it would be listed as a dep in the RPM. This sounds like an unmet dependency of systemd. The RPM packages provide a systemd unit file which is what systemd should be using for start the service. Each package also provides a SysV init script.

It's probably the presence of the init script that's triggering systemd to invoke insserv. So it makes sense that the stub insserv implementation fixes things since it doesn't really need to do anything besides satisfy systemd's usage of it.


(David Randall) #3

Andrew, thank you for taking the time to look into this. Before reporting to the openSUSE folks, I tried to reproduce but could not. A bare minimum install includes insserv, the same version as above. Systemd, however, advanced from systemd-234-lp150.19.1.x86_64 on the system above to systemd-234-lp150.20.3.1.x86_64 on a fresh install. I can only assume this was fixed in the systemd package or the install.

This is resolved.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.