Install dashboard fails Windows to Ubuntu

I have been struggling with getting filebeats (or winlogbeats - same errors) on Windows Server 2016 to install dashboards on my Ubuntu 16.04 server.
(Also tried on Windows 10 using internet, not internal network address - same issue)

Both boxes are on the same subnet in an AWS VPC. THe ELK stack works fine and the log files are being shipped; however, I have not been able to install dashboards from the windows server (I've tried others).

PS C:\Program Files\Filebeat> ./scripts/import_dashboards.exe -es
fail to create the Elasticsearch loader: Error creating Elasticsearch client: Couldn't connect to any of the configured
Elasticsearch hosts

I have tried many things including opening ports.

Elasticsearch is running fine (curl localhost:9200).

We are using nginx to redirect the kibana requests from port 80 to 5601.

I have searched around with no luck and gone through the manuals. It appears as though others have had this issue (July 17), but resolution was not stated.

I did not use x-pack.

Thank you.

Just in case others run into this...
The issue was resolved by changing the binding in the elasticsearch YML file to use instead of localhost.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.