Install Elasticsearch Service in Windows


(kiarash) #1

Elasticsearch service can not install in windows, When I run blow command:

.\elasticsearch-service.bat install

This output displayed in the command prompt:

C:\Users\Kiarash\Desktop\elasticsearch\bin>.\elasticsearch-service.bat install
Installing service      :  "elasticsearch-service-x64"
Using JAVA_HOME (64-bit):  "C:\Program Files\Java\jdk1.8.0_121"
'findstr /b \- "C:\Users\Kiarash\Desktop\elasticsearch\config\jvm.options" | findstr /b /v "\-server \-client"' is not recognized as an internal or external command,
operable program or batch file.
The syntax of the command is incorrect.

What is problem?


(Jason Tedor) #2

What version of Windows is this?


(kiarash) #3

Windows 10 Enterprise - x64


(Jason Tedor) #4

I think that findstr is not in your path. Please check your path and add C:\windows\system32 to your path if it's missing.


(kiarash) #5

@jasontedor No, findstr is in my path. The problem is elsewhere.


(Jason Tedor) #6

What do you think the issue is then?


(kiarash) #7

@jasontedor I tested findstr and that works fine, I do not know what the problem is.


#8

Try the following: In the Elasticsearch-service properties (.\elasticsearch-service.bat manager), under the Java tab, untick "use Default". stop/start service.


(kiarash) #9

@Leon_Nell When Elasticsearch Service can not be install How i can open Elasticsearch service manager?!!!

When i try open Elasticsearch service manager this message is displayed:


#10

Do you run your console (cmd or powershell) as Administrator by any chance?


(kiarash) #11

@Leon_Nell Yes


(kiarash) #12

@jasontedor After updating Windows 10 to Creators Update, Problem Solved!


(Jason Tedor) #13

Okay, that's good to know!


(system) #14

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.