Installation of Watcher on Windows fails

Hi,

I am trying to install Watcher on Windows.
But the commands fails.

Images below

Please help debugging the issue.

Thanks

Please don't post images of text as they are hard to read, may not display correctly for everyone, and are not searchable.

Instead, paste the text and format it with </> icon or pairs of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

Watcher is part of the default distribution. You don't have to install anything.

Hi David,

My Elastic installed, do not list watcher.

Tried the instructions on page - https://www.elastic.co/downloads/watcher

But install of Watcher failed on my Windows machine

When I ran the command:

elasticsearch-plugin install elasticsearch/license/latest

it give below messages:
--> Installing license
--> Failed installing license
--> Rolling back license
--> Rolled back license

Thanks,
Avijit

What did you install?

Those are instructions for a version 2.4.

elasticsearch-7.6.0 (Free trial)

So watcher is there. Unless you did not take the default distribution but the -oss one.

Hi David,

Ok, will then try uninstall and reinstall ELk

Thanks

Hi David,

When i run command on cmd:

\bin>elastisearch.bat

no plugins get installed. Below are couple of lines from bat file execution

[2020-03-13T08:44:23,675][INFO ][o.e.p.PluginsService ] [DESKTOP-DJC7G5I] loaded module [x-pack-watcher]
[2020-03-13T08:44:23,676][INFO ][o.e.p.PluginsService ] [DESKTOP-DJC7G5I] no plugins loaded

What should I do to get Watcher plugin loaded

Thanks,
Avijit

Did you notice this?

loaded module [x-pack-watcher]

Hi David,

Yes.

When I go to kibana and go to management tab under Elastic I don't see the Watcher listed there.

If I want that to show up there. What additional steps I need to take.

Thanks,
Avijit

You need to activate the trial license.
I guess you have the basic one for now?

Hi David,

Thanks a lot!

Now I am able to view the Watcher, after activating the trial license on Kibana

Regards,
Avijit

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.