Installing Logstash Plugins failing on Windows 10


(Patrick Ian) #1

Hi,

I'm using logstash 5.5 running on Windows 10 and I'm trying to install the logstash elapsed filter by running the command

./logstash-plugin install logstash-filter-elapsed

in the bin folder of my logstash installation. I get the following response

Validating logstash-filter-elapsed
Installing logstash-filter-elapsed
Error Bundler::InstallError, retrying 1/10
An error occurred while installing logstash-core (5.5.0), and Bundler cannot continue.
Make sure that `gem install logstash-core -v '5.5.0'` succeeds before bundling.

As far as I know, only JDK 8 is required for logstash and I've verified that I do have it. I've tried searching for similar cases but most of them are unresolved or do have HTTP problems. I don't think that connection is the case here, but I'm not sure now either.

I've already installed ruby and tried to run

gem install logstash-core -v '5.5.0'

but it's giving me errors as well. I've manually downloaded the gem file from rubyorg but it looks for manticore gem. I've installed manticore gem manually as well but when I try to run install the gem again, it still looks for the manticore gem as a dependency, I think.

Now, I don't really know ruby and I just want to install the elapsed filter and use it on my logstash. Any ideas on why this happens and are there any step-by-step alternatives on how to have the elapsed filter installed?


(Jake Landis) #2

I tried to reproduce from cmd and powershell on Windows 10, and both worked just fine.

PS Z:\workspace\upgrades\logstash-5.5.0\bin> ./logstash-plugin install logstash-filter-elapsed
Validating logstash-filter-elapsed
Installing logstash-filter-elapsed
Installation successful

I would suggest try again, or re-download a fresh copy of 5.5.0 and try again.


(Patrick Ian) #3

At first, I thought it might have had something to do with access rights to the folder so I made a copy in the desktop and ran the plugin installation from there using powershell and cmd but it gave me the same error. For now, I downloaded the gem manually from rubyorg and installed it as a local gem. I would not prefer this, however.

May I know how your copy was installed? Was it via extracting the zip file or was there something else you did? And are there additional steps aside from installing that I should have done?

Thank you.


(Jake Landis) #4

May I know how your copy was installed?

It was extracted from a zip from a fresh download of 5.5.0.


(Patrick Ian) #5

Huh. Interesting. Mine was the same. I'll try downloading a fresh copy today and let you know how it goes. Many Thanks.


(Patrick Ian) #6

Still failing...


(Joaquim Freitas) #7

Hi,

And what is the full path of your Logstash installation, by the way?
I smell spaces in the installation path, that crashes the execution of Logstash and the plugins installation...
Either that or installation path permissions.


(Patrick Ian) #8

C:\Users\<user>\Documents\logstash-5.5.0

user is my user name. It has no spaces. That's where I ran my last attempt at installing the plugin.


Logstash "WMI" input plugin Error ==> Error registering plugin
(Jake Landis) #9

@patrickian
I recently ran an into an issue on build machine recently that resulted in a similar issue.

Logstash has some very long path names, and can exceed the 260 character limit of Windows.

Assuming you have the most recent updates to Windows 10, you may try set this to 1

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem LongPathsEnabled

See


and
https://msdn.microsoft.com/en-us/library/aa365247(v=vs.85).aspx#maxpath


(system) #10

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.