Facing issue while installing any filter plugin such as logstash-filter-elapsed

Hi everyone,

I'm trying to install logstash-filter-elapsed on my logstash environment but I'm getting below error every time. I tried installing other plugins but still observe the same issue.

Can someone please help.

@nishug001 Welcome to our community forums!

The preferred way to work with Logstash plugins is to use our plugin manager.

In order to add the plugin to your environment, you could run the following command:

bin/logstash-plugin install logstash-filter-elapsed

I hope that helps.

Hi @ropc, thank you for your reply. I have tried

bin/logstash-plugin install logstash-filter-elapsed

too but still the same error. Just so you know, I'm trying to install it in my office virtual machine (Windows server 2016).


  1. When you run the bin/logstash-plugin command, is it the same error message as the one you shared previously? Please attach the logs.

  2. Are you able to reach RubyGems.org from the host running Logstash?

  3. Do you use any proxy in your environment? If so, you need to configure Logstash to use your proxy.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.