Integration Oracle Cloud Kafka + Elastic-agent doesn't work

Good afternoon. At the moment, there was an attempt to connect to collect logs from Oracle cloud Audit logs via Kafka, and everything worked through logstash. Now when I try to use Custom Kafka Integration in elasticsearch I get an error.

Logstash conf

\`
kafka {
bootstrap_servers =\> "server:9092"
topics =\> \["topic"\]
security_protocol =\> "SASL_SSL"
sasl_mechanism =\> "PLAIN"
jaas_path =\> "{PATH TO CONFIG}"
auto_offset_reset =\> "earliest"
consumer_threads =\> 1
}
}\``

JAAS

`\`#           KafkaClient {
org.apache.kafka.common.security.plain.PlainLoginModule required
username="tenant/username/streampool}}"
password="";
};\``

It's worked ok.

And when we use this is config for elastic-agent, it doesn't work

I'am use this is username and password and use kafka consumer group "elastic" and get error message

Error initializing kafka consumer group

kafka: couldn't fetch broker metadata (check that your client and broker are using the same encryption and authentication settings)

Also I try used port 9093 and get error Error initializing kafka consumer group

kafka: client has run out of available brokers to talk to (Is your cluster reachable?