Invalid setting error while saving "User settings (elasticsearch.yml)"


(pungent) #1

I have following settings for all nodes in my cluster:

Inline Scripts
Scripts can be inlined in requests, e.g. search requests. We recommend disabling this, or at most enabling sandboxed. --> selected ---> Enable sandboxed inline scripts

Then I went down and under User settings that will be appended to elasticsearch.yml, I put this

script.engine.groovy.inline.search: true and click update. But it keeps throwing "Invalid settings" error. May I know what am I doing wrong, or how can I achieve what I am trying to do?


(Isabel Drost-Fromm) #2

What version of ES are you using? Is there any additional information printed to the "Invalid settings" error? (Asking because I would expect the offending setting to be printed as well.)


(pungent) #3

ES 2.3.5 , I just get the popup bubble on top right corner of the "configuration" page saying "invalid settings". That's all.


(Isabel Drost-Fromm) #4

"popup bubble" sounds like you are using Kibana on top of Elasticsearch?

Reading
https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-scripting.html it looks like the scripting language you are trying to enable (groovy) is not a sandboxed scripting language, it also lists what other options you will need to enable to use groovy.

As an aside - may I ask what use case you are trying to solve with using groovy?

Hope this helps,
Isabel


(system) #5