Enable script inline elasticsearch 2.3, unable to restart elasticsearch fails


(Pradeep Sathyaraj) #1

POST /customer/external/1/_update?pretty
{
"script" : "ctx._source.age += 5"
}

I got this error,
"reason": "scripts of type [inline], operation [update] and lang [groovy] are disabled"

I update elasticsearch.yml with

script.inline: true
script.indexed: true

So after unable to restart elasticsearch


(Daniel Mitterdorfer) #2

Hi @Pradeep_Sathyaraj,

Can you please post the exact failure you get when you restart Elasticsearch?

Daniel


(Pradeep Sathyaraj) #3

Hi @danielmitterdorfer

I found the issue in the elasticsearch.yml, I enable a node and cofigure like below and started working

node.name: node-1
script.inline: true
script.indexed: true

Thanks for your reply


(Daniel Mitterdorfer) #4

Hi @Pradeep_Sathyaraj,

that's great. Glad that it's working now.

Daniel


(Maggie) #5

I'm facing the same issue in ES 5.2.2
Did someone face the same issue in ES 5.2.2 ?


(system) #6