Is _id of document affects on scoring?

I add two same documents the only different thing is _id of documents (I
restart scenario for each of them and I do not add them sequentially. to be
sure my test is correct)

one of them changes order of result of this query and one of them does not:

GET index_for_test/business/_search
{

"query": {
        "multi_match": {
        "query":       "italian",
        "type":        "most_fields",
        "fields":      [ "name^10", "categories" ]
      }
}

}

i think it should be bug

my original question was:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5d0eba0f-0809-4a68-b247-0640addb9119%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

The difference is probably due to the fact that your documents ended on
different shards where doc frequencies are different. You should be able to
make it a bit better by using distributed frequencies.

On Tue, Mar 31, 2015 at 3:18 PM, Mohammad.R esmailzadeh <
esmailzadeh@gmail.com> wrote:

I add two same documents the only different thing is _id of documents (I
restart scenario for each of them and I do not add them sequentially. to be
sure my test is correct)

one of them changes order of result of this query and one of them does
not:

GET index_for_test/business/_search
{

"query": {
        "multi_match": {
        "query":       "italian",
        "type":        "most_fields",
        "fields":      [ "name^10", "categories" ]
      }
}

}

i think it should be bug

my original question was:

https://github.com/elastic/elasticsearch/issues/10341

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5d0eba0f-0809-4a68-b247-0640addb9119%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/5d0eba0f-0809-4a68-b247-0640addb9119%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Adrien

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAO5%3DkAg-z%3DDqNptG14Ekp_czAYLxCZXYkgzK%3DokV3X9f6d%2BvSA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Thanks for your response.
it is completely confusing for me why elasticsearch was configured for
large data by default instead of development and developers should find
these tiny tips under thousands of documentations.
On Tuesday, 31 March 2015 17:54:00 UTC+4:30, Adrien Grand wrote:

The difference is probably due to the fact that your documents ended on
different shards where doc frequencies are different. You should be able to
make it a bit better by using distributed frequencies.
https://www.elastic.co/blog/understanding-query-then-fetch-vs-dfs-query-then-fetch

On Tue, Mar 31, 2015 at 3:18 PM, Mohammad.R esmailzadeh <
esmai...@gmail.com <javascript:>> wrote:

I add two same documents the only different thing is _id of documents (I
restart scenario for each of them and I do not add them sequentially. to be
sure my test is correct)

one of them changes order of result of this query and one of them does
not:

GET index_for_test/business/_search
{

"query": {
        "multi_match": {
        "query":       "italian",
        "type":        "most_fields",
        "fields":      [ "name^10", "categories" ]
      }
}

}

i think it should be bug

my original question was:

https://github.com/elastic/elasticsearch/issues/10341

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/5d0eba0f-0809-4a68-b247-0640addb9119%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/5d0eba0f-0809-4a68-b247-0640addb9119%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
Adrien

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b78aa9d8-2e22-40a3-b36b-5817fd2567ef%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

On Tue, Mar 31, 2015 at 4:13 PM, Mohammad.R esmailzadeh <
esmailzadeh@gmail.com> wrote:

it is completely confusing for me why elasticsearch was configured for
large data by default instead of development and developers should find
these tiny tips under thousands of documentations.

I'm sorry you had a bad experience. I don't really have a good answer for
you here: the right value for a particular setting depends on your usage of
elasticsearch and while we strive at having good defaults, they can't
always be right for everyone.

In case you missed it, there is a free book about elasticsearch (
http://www.elastic.co/guide/en/elasticsearch/guide/current/index.html)
which you can read and dives you into how elasticsearch works and how to
use it so that you don't have to crawl the reference API every time that
you start using a new API.

--
Adrien

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAO5%3DkAgPajZ5Qn4_RFnJ1Y6KxfAWg8i2d8C2u54OYe_QgEss4w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.