Is path.repo needed to register a snapshot repository for "type" = "s3"? (elasticsearch 1.7.4)

I am getting this error

  1. Error injecting constructor, org.elasticsearch.repositories.RepositoryException: [repository] location [backup] doesn't match any of the locations specified by path.repo because this setting is empty
    at org.elasticsearch.repositories.fs.FsRepository.(Unknown Source)
    while locating org.elasticsearch.repositories.fs.FsRepository
    while locating org.elasticsearch.repositories.Repository

1 error
at org.elasticsearch.common.inject.internal.Errors.throwCreationExceptionIfErrorsExist(

I am really new at this. So, I apologize for newbie questions.

I am using "type": "s3" then why do I need to set path.repo entry?

Thank you for the help

Indeed. If you are using "type": "s3", we should probably not check if path.repo has been defined.
Might be a bug. Might have been fixed in 2.x though.

@Igor_Motov thoughts?

adding path.repo=["s3"] works for me. But it seems to be a work around to avoid ES throwing the error.

@Vishal_Singh1 is it possible that you had another FS repository registered?

Yes, I checked. I have 3 repository and one of them is FS repository. That will explain the problem :slightly_smiling:
I wish that the error is not thrown when I was trying to register S3. Thanks again for explaining it to me :slight_smile:

@Vishal_Singh1 That looks like a bug. I thought we fixed it in 1.5.1 though. If you can reproduce it, could you open an issue for it?

Hi Team,

I've just tried using both s3 and fs snapshot repos with and without the path.repo line in the elasticsearch config on v2.3.1 and got expected results.

The path.repo isn't required for creating an s3 snapshot repository in the version I tested.

I can test other versions out if people are still seeing issues with older versions so that we can confirm?