Is there any basic tutorial of nodes networking?


(Jongmin Kim) #1

I'm trying to open nodes on two networks.

node1's IP address is 192.168.0.40. I didn't change any config, just run.

$ bin/elasticsearch
[2014-03-09 19:44:44,325][INFO ][node ] [Daytripper]
version[1.0.1], pid[25038], build[5c03844/2014-02-25T15:52:53Z]
[2014-03-09 19:44:44,325][INFO ][node ] [Daytripper]
initializing ...
[2014-03-09 19:44:44,330][INFO ][plugins ] [Daytripper]
loaded [], sites []
[2014-03-09 19:44:46,961][INFO ][node ] [Daytripper]
initialized
[2014-03-09 19:44:46,961][INFO ][node ] [Daytripper]
starting ...
[2014-03-09 19:44:47,075][INFO ][transport ] [Daytripper]
bound_address {inet[/192.168.0.40:9300]}, publish_address
{inet[/192.168.0.40:9300]}
[2014-03-09 19:44:50,118][INFO ][cluster.service ] [Daytripper]
new_master
[Daytripper][ng1JmedNTEanvsnpI_Yw-g][Jongminui-MacBook-Pro.local][inet[/192.168.0.40:9300]],
reason: zen-disco-join (elected_as_master)
[2014-03-09 19:44:50,142][INFO ][discovery ] [Daytripper]
elasticsearch/ng1JmedNTEanvsnpI_Yw-g
[2014-03-09 19:44:50,156][INFO ][http ] [Daytripper]
bound_address {inet[/192.168.0.40:9200]}, publish_address
{inet[/192.168.0.40:9200]}
[2014-03-09 19:44:50,170][INFO ][gateway ] [Daytripper]
recovered [0] indices into cluster_state
[2014-03-09 19:44:50,170][INFO ][node ] [Daytripper]
started

Node2 is on the same subnet. IP is 192.168.0.42
I changed config/elasticsearch.yml

network.bind_host: 192.168.0.40

and run it. but it does not bind.

bin/elasticsearch [2014-03-09 19:57:22,698][WARN ][bootstrap ] jvm uses the
client vm, make sure to run java with the server vm for best performance
by adding -server to the command line [2014-03-09 19:57:22,764][INFO
][node ] [Uni-Mind] version[1.0.1], pid[2811],
build[5c03844/2014-02-25T15:52:53Z] [2014-03-09 19:57:22,764][INFO ][node ]
[Uni-Mind] initializing ... [2014-03-09 19:57:22,767][INFO ][plugins ]
[Uni-Mind] loaded [], sites [] [2014-03-09 19:57:24,532][INFO ][node ]
[Uni-Mind] initialized [2014-03-09 19:57:24,532][INFO ][node ] [Uni-Mind]
starting ... {1.0.1}: Startup Failed ... - BindTransportException[Failed to
bind to [9300-9400]] ChannelException[Failed to bind to: /192.168.0.40:9400]
BindException[Cannot assign requested address] <goog_346293252>
http://192.168.0.40:9400/
192.168.0.40

what I expected was if I set
# network.bind_host: [master node's IP]
than it will bind on the same cluster.

Did I miss something?

And one more thing. If there is any example I can make network bind between
AWS EC2 instances. (in the same region)

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/39128129-9467-4673-aba1-a38a7dd776eb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

network.bind_host tells the node to bind the ES process to that IP. ie You're
saying you want ES to bind to the IP address of the master, which doesn't
exist on that machine.

Take a look at http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/or
http://www.elasticsearch.cn/guide/reference/modules/discovery/ec2.html for
AWS stuff.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 9 March 2014 22:04, Jong Min Kim kimjmin@gmail.com wrote:

I'm trying to open nodes on two networks.

node1's IP address is 192.168.0.40. I didn't change any config, just run.

$ bin/elasticsearch
[2014-03-09 19:44:44,325][INFO ][node ] [Daytripper]
version[1.0.1], pid[25038], build[5c03844/2014-02-25T15:52:53Z]
[2014-03-09 19:44:44,325][INFO ][node ] [Daytripper]
initializing ...
[2014-03-09 19:44:44,330][INFO ][plugins ] [Daytripper]
loaded [], sites []
[2014-03-09 19:44:46,961][INFO ][node ] [Daytripper]
initialized
[2014-03-09 19:44:46,961][INFO ][node ] [Daytripper]
starting ...
[2014-03-09 19:44:47,075][INFO ][transport ] [Daytripper]
bound_address {inet[/192.168.0.40:9300]}, publish_address {inet[/
192.168.0.40:9300]}
[2014-03-09 19:44:50,118][INFO ][cluster.service ] [Daytripper]
new_master
[Daytripper][ng1JmedNTEanvsnpI_Yw-g][Jongminui-MacBook-Pro.local][inet[/192.168.0.40:9300]],
reason: zen-disco-join (elected_as_master)
[2014-03-09 19:44:50,142][INFO ][discovery ] [Daytripper]
elasticsearch/ng1JmedNTEanvsnpI_Yw-g
[2014-03-09 19:44:50,156][INFO ][http ] [Daytripper]
bound_address {inet[/192.168.0.40:9200]}, publish_address {inet[/
192.168.0.40:9200]}
[2014-03-09 19:44:50,170][INFO ][gateway ] [Daytripper]
recovered [0] indices into cluster_state
[2014-03-09 19:44:50,170][INFO ][node ] [Daytripper]
started

Node2 is on the same subnet. IP is 192.168.0.42
I changed config/elasticsearch.yml

network.bind_host: 192.168.0.40

and run it. but it does not bind.

bin/elasticsearch [2014-03-09 19:57:22,698][WARN ][bootstrap ] jvm uses
the client vm, make sure to run java with the server vm for best
performance by adding -server to the command line [2014-03-09
19:57:22,764][INFO ][node ] [Uni-Mind] version[1.0.1], pid[2811],
build[5c03844/2014-02-25T15:52:53Z] [2014-03-09 19:57:22,764][INFO ][node ]
[Uni-Mind] initializing ... [2014-03-09 19:57:22,767][INFO ][plugins ]
[Uni-Mind] loaded [], sites [] [2014-03-09 19:57:24,532][INFO ][node ]
[Uni-Mind] initialized [2014-03-09 19:57:24,532][INFO ][node ] [Uni-Mind]
starting ... {1.0.1}: Startup Failed ... - BindTransportException[Failed to
bind to [9300-9400]] ChannelException[Failed to bind to: /
192.168.0.40:9400] BindException[Cannot assign requested address]http://goog_346293252
http://192.168.0.40:9400/
192.168.0.40

what I expected was if I set
# network.bind_host: [master node's IP]
than it will bind on the same cluster.

Did I miss something?

And one more thing. If there is any example I can make network bind
between AWS EC2 instances. (in the same region)

Thanks in advance.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/39128129-9467-4673-aba1-a38a7dd776eb%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/39128129-9467-4673-aba1-a38a7dd776eb%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624a_CcYb3hFg1HRBT3N%2BPP5gtWR9oYzRooxFM5_XUnNeHQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3