Issue(Data might be incomplete because your request timed out)

I migrated data to elastic-cloud recently, but Kibana can not complete my request. It always says "Data might be incomplete because your request timed out" when I set time range over 24hours. I checked the request statistics on Kibana, Query time was 261ms and Request time was 469ms. It didn't over the default timeout of Kibana(300000ms). I tried to upgrade my elasticsearch and kibana's RAM, but it didn't work. How can I fix it?

Please see on how to raise a support ticket for Elastic Cloud :slight_smile:

Just to add another data point - we are seeing the same thing after updating our cloud deployment to v6.5.3. We were on v6.5.1 previously and had never seen the "Data might be incomplete because your request timed out" message and now see it constantly even at less than 24 hour time range. Searches are performed in under 1000ms. If I reload the same search I get different amounts of data each time.

I'm interestested in this as well. We also started having the issue once we updated to 6.5.3. Queries were happening quickly, but still getting the message (and partial data).

I noticed that 6.5.4 dropped last night in elastic cloud.

Does anyone know if that would fix this issue or not?

Upgraded today to v6.5.4 and the issue has gone away. Hopefully others will have the same experience.

It may have been this bug

1 Like

This also worked for me. Thanks for responding back!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.