Issue with FSCrawler (fscrawler-es7-2.7) . Refusing to upload new files . Warning: set filename as stored field!

We are facing an issue with FSCrawler (fscrawler-es7-2.7). FSCrawler is refusing to upload new files and raises the below error:

 08:37:04,730 WARN  [f.p.e.c.f.FsParserAbstract] Error while crawling \SearchEngineFiles\Development Francois\Development
 Francois\ConfigurationData\UploadedFiles: Mapping is incorrect: please set stored: true on field [file.filename].
08:37:08,277 WARN  [o.e.c.RestClient] request [POST http://192.168.1.34:9200/_bulk?timeout=1m] returned 1 warnings: [299

Below is the settings for FSCrawler:

---
name: "vsearch"
fs:
  url: "\\SearchEngineFiles\\Development Francois\\Development Francois\\ConfigurationData\\UploadedFiles\\"
  update_rate: "5s"
  excludes:
  - "*/~*"
  json_support: false
  filename_as_id: false
  add_filesize: true
  remove_deleted: true
  add_as_inner_object: false
  store_source: false
  index_content: true
  attributes_support: false
  raw_metadata: false
  xml_support: false
  index_folders: true
  lang_detect: false
  continue_on_error: false
  ocr:
    language: "eng"
    enabled: true
    pdf_strategy: "ocr_and_text"
  follow_symlinks: false
elasticsearch:
  nodes:
  - url: "http://192.168.1.34:9200"
  bulk_size: 100
  flush_interval: "5s"
  byte_size: "10mb"
  ssl_verification: true

On Elasticsearch no error is being raised.

I tried to change the mapping from Kibana using the following code:

PUT /vsearch/_mapping
{
   "properties" : {

        "file" : {
          "properties" : {
            "filename" : {
             "store":"true" ,
              "type" : "text",
              "fields" : {
                "keyword" : {
                  "type" : "keyword",
                  "ignore_above" : 256
                }
              }
            }
          }
        }
   }
}

We got the following:

{
  "error" : {
    "root_cause" : [
      {
        "type" : "illegal_argument_exception",
        "reason" : "Mapper for [file.filename] conflicts with existing mapper:\n\tCannot update parameter [store] from [false] to [true]"
      }
    ],
    "type" : "illegal_argument_exception",
    "reason" : "Mapper for [file.filename] conflicts with existing mapper:\n\tCannot update parameter [store] from [false] to [true]"
  },
  "status" : 400
}

What can be done in this case?

You can not update the mapping of an existing index.
You need to delete the index and recreate it.