Issue with setting `_tier_preference` in index template

Hello
We are encountering an issue while trying to set the _tier_preference in an index template. Despite updating the setting in the index template edit page, the preview shows that _tier_preference is set to null instead of the expected value data_hot.

Here is the JSON snippet we are using in the index template edit page:

{
  "index": {
    "lifecycle": {
      "name": "test-ilm"
    },
    "routing": {
      "allocation": {
        "include": {
          "_tier_preference": "data_hot"
        }
      }
    },
    "number_of_shards": "4",
    "number_of_replicas": "1"
  }
}

And here is an extract of the preview

{
  "settings": {
    "index": {
      "lifecycle": {
        "name": "test-ilm"
      },
      "routing": {
        "allocation": {
          "include": {
            "_tier_preference": null
          }
        }
      },
      "number_of_shards": "4",
      "number_of_replicas": "1"
    }
  },
  ...
}

We know the _tier_preference is not setting to data_hot, because whenever an index is created, it's tier preference is data_content (he default value).
Does anyone have any insight on what could be happening?
Extra information:

  • We are using Elasticsearch 8.11.3.
  • Our cluster has four nodes: two hot zones and two warm zones.

Thank you in advance,
Sebasti√°n

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.