Issues with index routing allocation in 1.3.1


(James Dooley) #1

I noticed an issue after upgrading from 0.90.9 to 1.3.1 that the
index.routing.allocation.include._ip setting per index is not being
properly handled.
I have used this setting in the past to move indices to an arching server
for long term storage (outside of the cluster).

In the past the past I have been able to do the following:

Pre-move settings:
'index' => {
'number_of_replicas' => '2',
'version' => {
'created' => '900999'
},
'number_of_shards' => '4',
'uuid' => 'xt8LJlsbR6COhx612BhiWg',
'routing' => {
'allocation' => {
'include' => {
'tag'
=> 'storage',
},

'total_shards_per_node' => '2'
}
}
}
};

Move settings:
'index' => {
'number_of_replicas' => '2',
'version' => {
'created' => '900999'
},
'number_of_shards' => '4',
'uuid' => 'xt8LJlsbR6COhx612BhiWg',
'routing' => {
'allocation' => {
'include' => {
'tag'
=> '',
'_ip'
=> '192.168.0.51',
},

'total_shards_per_node' => '999'
}
}
}
};

This would force one copy of each shard to migrate to the archiving server
from the storage cluster.

Now in 1.3.1 the shards do not move at all with these settings, instead I
have to set the following (which is incorrect):
'index' => {
'number_of_replicas' => '2',
'version' => {
'created' => '900999'
},
'number_of_shards' => '4',
'uuid' => 'xt8LJlsbR6COhx612BhiWg',
'routing' => {
'allocation' => {
'include' => {
'tag'
=> 'storage,backup',
'_ip'
=> '192.168.0.51',
},

'total_shards_per_node' => '999'
}
}
}
};

According to the documentation "This is in contrast to include which will
include a node if ANY rule matches."

I did a quick test and it does look like if I do not provide the _ip
setting, but only use the tags setting the migration works as intended.
This leads me to believe that the _ip field is being completely ignored.
In my use case I can't rely on the backup tag since I will have more than
one backup server (using that tag), but need all of the data to go to a
single server (ie need _ip, _host etc).

Unfortunately, I was running on an old cluster for awhile so I am not sure
exactly where this broke at. But would have been somewhere between 0.90.9
and 1.3.1.
Has anyone else run in to this issue?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f3a6af2c-7632-4329-8806-0dd0ae589068%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2