Issues with Topbeat --> ES since version 1.0.0-rc1


(Josh) #1

Title says it all really,

I am unable to get any metrics to be sent to Elastic search since upgrading topbeat to version 1.0.0-rc1 on Centos 6.

I cant see anything in system logs and everything starts up without any issues.

can you recommend where to look to see where it is failing?

Thanks.


(ruflin) #2

Can start up topbeat with -e -d "*" flag. Thiw will output the debug messages. There you should find some more information and you can also post it here for further analysis.


(Josh) #3

Thanks for the advice but this hasnt really pointed to anything new

[root@##### ~]# topbeat --version
topbeat version 1.0.0-rc1 (amd64)
[root@##### ~]# topbeat -e -d "*"
2015/11/18 11:56:05.588635 beat.go:94: DBG  Initializing output plugins
2015/11/18 11:56:05.588664 geolite.go:52: WARN Couldn't load GeoIP database

I do find that it is trying to load the GeoIP database as the release notes say it was disabled by default.

Disable geoip by default. To enable it uncomment in config file. #305


(Tudor Golubenco) #4

The GeoIP is made default false in RC2, and you have RC1. Just to make sure, by default topbeat reads the stats every 10 seconds, did you waited that long while running it in foreground?


(Steffen Siering) #5

since rc1, the outputer will probe for elasticsearch to be available. For probing a HTTP HEAD message is used (similar to GET, but response as no message body). You running ES behind a proxy/firewall?

Can you try http://es-hostname:es-port from any browser? You see some JSON output?

Also with curl you can try elasticsearch probing via:

curl -XHEAD http://es-hostname:es-port

(system) #6