Issues with using the plugin command

Hello,

I am trying to download and use the mapper attachment plugin. I have
elastic search downloaded on a linux machine. I download the zip file of
2.3.2 and unzipped it. Once I did this no .jar files were added to my lib
and elastic search couldn't detect the plugin. I downloaded the plugin like
this instead of using the plugin install file/path because for some reason
plugin doesn't work as a command on my machine. If some one knows why this
is happening that would be awesome. I directed elastic search to the
correct plugin folder in the .yml file so I am just very confused as to how
to get this working. When I run this command: curl -XGET
'http://localhost:9200/_nodes' I get all the usual information but at the
end where the plugins are supposed to show nothing is showing up. Can
someone point me to the right file to download or tell me what they think
I'm doing wrong. My plugin folder is at this file path:
/usr/share/elasticsearch/plugins/mapper-attachments/ I've tried putting it
in use/share/elasticsearch/bin/plugins and I've tried
/usr/share/elasticsearch/lib and neither work.

Thank you,
Austin Harmon

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1e6acba2-5686-4060-b9b6-dafffe848951%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Could you run:

ls -l /usr/share/elasticsearch/plugins/mapper-attachments/

Could you explain what error you have when you try to install using the official plugin command?
Also try with -v option

Could you tell which ZIP file you downloaded?

When you restart elasticsearch, what are the first lines of logs. You should see plugins there.

What gives GET /_cat/plugins?v

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 27 févr. 2015 à 23:02, Austin Harmon aharmon2165@gmail.com a écrit :

Hello,

I am trying to download and use the mapper attachment plugin. I have elastic search downloaded on a linux machine. I download the zip file of 2.3.2 and unzipped it. Once I did this no .jar files were added to my lib and elastic search couldn't detect the plugin. I downloaded the plugin like this instead of using the plugin install file/path because for some reason plugin doesn't work as a command on my machine. If some one knows why this is happening that would be awesome. I directed elastic search to the correct plugin folder in the .yml file so I am just very confused as to how to get this working. When I run this command: curl -XGET 'http://localhost:9200/_nodes' I get all the usual information but at the end where the plugins are supposed to show nothing is showing up. Can someone point me to the right file to download or tell me what they think I'm doing wrong. My plugin folder is at this file path: /usr/share/elasticsearch/plugins/mapper-attachments/ I've tried putting it in use/share/elasticsearch/bin/plugins and I've tried /usr/share/elasticsearch/lib and neither work.

Thank you,
Austin Harmon

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1e6acba2-5686-4060-b9b6-dafffe848951%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/1e6acba2-5686-4060-b9b6-dafffe848951%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/17F99A33-0D67-498A-9017-B794BAB58DE8%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.