It seems impossible to modify/delete an index after setting blocks.read_only=true

I have an index, let's call it myindex, and I updated the settings to make
it read-only like so:
PUT myindex/_settings {"blocks": { "read_only": "true" }}
This worked as expected, but now I am stuck! I need to delete this index,
but I cannot modify this index because blocks.read_only also disables
meta-data updates.

I tried to do undo it like so, but it failed:

PUT myindex/_settings {"blocks": { "read_only": "false" }}

ClusterBlockException[blocked by: [FORBIDDEN/5/index read-only (api)];];

So I thought closing it first would help, but that failed too:

POST myindex/_close

ClusterBlockException[blocked by: [FORBIDDEN/5/index read-only (api)];];

Deleting the index failed with the same exception.

Am I stuck with this index until then end of time!?!

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To view this discussion on the web visit
For more options, visit