Issue removing index with index.blocks.read_only set to true

Hi,

I was trying the settings to block data writes and also metadat writes to
an index applying this:

curl -XPUT 'http://testserver:9200/test_index/_settings' -d '{
"index.blocks.read_only" : "true"
}'

which works fine but now I would like to remove this index and I'm facing
this issue;

{"error":"RemoteTransportException[[lonsl1101844-master][inet[/10.243.1.10:9300]][indices:admin/delete]];
nested: ClusterBlockException[blocked by: [FORBIDDEN/5/index read-only
(api)];]; ","status":403}

I can't change anymore the configuration of the index as metdata writes are
forbidden.

I also now have an issues with my different monitoring tools as they are
using get _settings/_aliases.. request which are forbidden for this index.

Could you please indicate me how I can force the remove of this index or
change its configuration?

Thanks,
Nicolas

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/06aaed45-0208-4e4f-8c3e-d58adf93a388%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Just set that value to false and you should be good to go.

On 29 January 2015 at 23:58, 'Nicolas Fraison' via elasticsearch <
elasticsearch@googlegroups.com> wrote:

Hi,

I was trying the settings to block data writes and also metadat writes to
an index applying this:

curl -XPUT 'http://testserver:9200/test_index/_settings' -d '{
"index.blocks.read_only" : "true"
}'

which works fine but now I would like to remove this index and I'm facing
this issue;

{"error":"RemoteTransportException[[lonsl1101844-master][inet[/10.243.1.10:9300]][indices:admin/delete]];
nested: ClusterBlockException[blocked by: [FORBIDDEN/5/index read-only
(api)];]; ","status":403}

I can't change anymore the configuration of the index as metdata writes
are forbidden.

I also now have an issues with my different monitoring tools as they are
using get _settings/_aliases.. request which are forbidden for this index.

Could you please indicate me how I can force the remove of this index or
change its configuration?

Thanks,
Nicolas

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/06aaed45-0208-4e4f-8c3e-d58adf93a388%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/06aaed45-0208-4e4f-8c3e-d58adf93a388%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X9XmE8unKH9JYz1r9CvyXO5A8%3DpGkeoXTMWBdQQz0S4cQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

I have the same problem. You can't change the value to false because
metadata udpates are blocked and changing the value is itself a metadata
update!
Is there any way to delete this index now!?

On Thursday, January 29, 2015 at 3:46:22 PM UTC-6, Mark Walkom wrote:

Just set that value to false and you should be good to go.

On 29 January 2015 at 23:58, 'Nicolas Fraison' via elasticsearch <
elasti...@googlegroups.com <javascript:>> wrote:

Hi,

I was trying the settings to block data writes and also metadat writes to
an index applying this:

curl -XPUT 'http://testserver:9200/test_index/_settings' -d '{
"index.blocks.read_only" : "true"
}'

which works fine but now I would like to remove this index and I'm facing
this issue;

{"error":"RemoteTransportException[[lonsl1101844-master][inet[/10.243.1.10:9300]][indices:admin/delete]];
nested: ClusterBlockException[blocked by: [FORBIDDEN/5/index read-only
(api)];]; ","status":403}

I can't change anymore the configuration of the index as metdata writes
are forbidden.

I also now have an issues with my different monitoring tools as they are
using get _settings/_aliases.. request which are forbidden for this index.

Could you please indicate me how I can force the remove of this index or
change its configuration?

Thanks,
Nicolas

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/06aaed45-0208-4e4f-8c3e-d58adf93a388%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/06aaed45-0208-4e4f-8c3e-d58adf93a388%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5f5f576a-bf33-44af-b671-e616b40e91af%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi,
If I remuer well the isssue of setting back the read-only setting to false was due to the fact that I was performing a Put instead of a post or the opposite.
Let me know if it help you, if no I will look at some old scripts that I should have kept with this.
Nicolas
jeudi, 02 avril 2015, 03:55PM +02:00 de BradVido bradyvidovic@gmail.com:

I have the same problem. You can't change the value to false because metadata udpates are blocked and changing the value is itself a metadata update!
Is there any way to delete this index now!?
On Thursday, January 29, 2015 at 3:46:22 PM UTC-6, Mark Walkom wrote:

Just set that value to false and you should be good to go.

On 29 January 2015 at 23:58, 'Nicolas Fraison' via elasticsearch < elasti...@googlegroups.com > wrote:

Hi,

I was trying the settings to block data writes and also metadat writes to an index applying this:
curl -XPUT
' http://testserver:9200/test_index/_settings ' -d ' {

"index.blocks.read_only" : "true"

}'

which works fine but now I would like to remove this index and I'm facing this issue;
{"error":"RemoteTransportException[[lonsl1101844-master][inet[/10.243.1.10:9300]][indices:admin/delete]];
nested: ClusterBlockException[blocked by: [FORBIDDEN/5/index read-only
(api)];]; ","status":403}

I can't change anymore the configuration of the index as metdata writes are forbidden.

I also now have an issues with my different monitoring tools as they are using get _settings/_aliases.. request which are forbidden for this index.
Could you please indicate me how I can force the remove of this index or change its configuration?
Thanks,
Nicolas

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com .
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/06aaed45-0208-4e4f-8c3e-d58adf93a388%40googlegroups.com .
For more options, visit https://groups.google.com/d/optout .

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/JkGihq3zcQw/unsubscribe .
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com .
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5f5f576a-bf33-44af-b671-e616b40e91af%40googlegroups.com .
For more options, visit https://groups.google.com/d/optout .

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1427989358.488102988%40f12.my.com.
For more options, visit https://groups.google.com/d/optout.