How to revert metadata blocking?


(ramazan) #1

Hi,

I am facing an issue related to the metadata blocking setting.
I told ES to disable the metadata changes for an index using update API but
don't know how to revert it back.

I tried reverting it back using the fallowing command while the index in
close state.

curl -XPUT 'http://127.0.0.1:9200/test1/_settings'
{
"index": {
"blocks":{
"metadata":false
}
}

}

Bu it returned:

{

  • error: ClusterBlockException[blocked by: [FORBIDDEN/4/index
    closed];[FORBIDDEN/8/index write (api)];]
  • status: 403

}

Here is the gist:

I hope someone help me.

NOTE: I am using a few day old master branch of ES.

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #2

Hi,

I can't reproduce your error on master. My guess is that it is because the
curl syntax misses a -d parameter on the end. This causes no body to be sent

curl -XPUT "http://localhost:9200/test/_settings" -d'
{
"index": {
"blocks":{
"metadata":false
}
}
}'

I was wondering - why do you need to put a metadata block on a closed index?

On Sunday, October 27, 2013 8:32:59 PM UTC+1, rkar...@gmail.com wrote:

Hi,

I am facing an issue related to the metadata blocking setting.
I told ES to disable the metadata changes for an index using update API
but don't know how to revert it back.

I tried reverting it back using the fallowing command while the index in
close state.

curl -XPUT 'http://127.0.0.1:9200/test1/_settings'
{
"index": {
"blocks":{
"metadata":false
}
}

}

Bu it returned:

{

  • error: ClusterBlockException[blocked by: [FORBIDDEN/4/index
    closed];[FORBIDDEN/8/index write (api)];]
  • status: 403

}

Here is the gist:
https://gist.github.com/rkarakaya/7186753

I hope someone help me.

NOTE: I am using a few day old master branch of ES.

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(ramazan) #3

Hi,
Hi,

I'll retry this with the latest master code.
I wrote down curl commands just to explain the issue. I am not directly
using curl.

I was wondering - why do you need to put a metadata block on a closed
index?
I don't need actually :slight_smile:
More than a year, I am working on an ES administration tool (Web based). I
encountered this issue while I am testing my gui.

On Monday, October 28, 2013 2:43:34 PM UTC+2, Boaz Leskes wrote:

Hi,

I can't reproduce your error on master. My guess is that it is because the
curl syntax misses a -d parameter on the end. This causes no body to be sent

curl -XPUT "http://localhost:9200/test/_settings" -d'
{
"index": {
"blocks":{
"metadata":false
}
}
}'

I was wondering - why do you need to put a metadata block on a closed
index?

On Sunday, October 27, 2013 8:32:59 PM UTC+1, rkar...@gmail.com wrote:

Hi,

I am facing an issue related to the metadata blocking setting.
I told ES to disable the metadata changes for an index using update API
but don't know how to revert it back.

I tried reverting it back using the fallowing command while the index in
close state.

curl -XPUT 'http://127.0.0.1:9200/test1/_settings'
{
"index": {
"blocks":{
"metadata":false
}
}

}

Bu it returned:

{

  • error: ClusterBlockException[blocked by: [FORBIDDEN/4/index
    closed];[FORBIDDEN/8/index write (api)];]
  • status: 403

}

Here is the gist:
https://gist.github.com/rkarakaya/7186753

I hope someone help me.

NOTE: I am using a few day old master branch of ES.

Thanks.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Leonardo Menezes) #4

maybe this is related:

Leonardo Menezes
http://lmenezes.com

http://twitter.com/leonardomenezes

On Thu, Oct 31, 2013 at 9:24 PM, rkarakaya@gmail.com wrote:

Hi,
Hi,

I'll retry this with the latest master code.
I wrote down curl commands just to explain the issue. I am not directly
using curl.

I was wondering - why do you need to put a metadata block on a closed
index?
I don't need actually :slight_smile:
More than a year, I am working on an ES administration tool (Web based). I
encountered this issue while I am testing my gui.

On Monday, October 28, 2013 2:43:34 PM UTC+2, Boaz Leskes wrote:

Hi,

I can't reproduce your error on master. My guess is that it is because
the curl syntax misses a -d parameter on the end. This causes no body to be
sent

curl -XPUT "http://localhost:9200/test/_**settingshttp://localhost:9200/test/_settings"
-d'
{
"index": {
"blocks":{
"metadata":false
}
}
}'

I was wondering - why do you need to put a metadata block on a closed
index?

On Sunday, October 27, 2013 8:32:59 PM UTC+1, rkar...@gmail.com wrote:

Hi,

I am facing an issue related to the metadata blocking setting.
I told ES to disable the metadata changes for an index using update API
but don't know how to revert it back.

I tried reverting it back using the fallowing command while the index in
close state.

curl -XPUT 'http://127.0.0.1:9200/test1/_**settings http://127.0.0.1:9200/test1/_settings'
{
"index": {
"blocks":{
"metadata":false
}
}

}

Bu it returned:

{

  • error: ClusterBlockException[**blocked by: [FORBIDDEN/4/index
    closed];[FORBIDDEN/8/index write (api)];]
  • status: 403

}

Here is the gist:
https://gist.github.com/**rkarakaya/7186753https://gist.github.com/rkarakaya/7186753

I hope someone help me.

NOTE: I am using a few day old master branch of ES.

Thanks.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(ramazan) #5

yes. it seems similar.

My workaround is :
Don't allow user to change this setting :slight_smile:

On Thursday, October 31, 2013 10:58:06 PM UTC+2, Leonardo Menezes wrote:

maybe this is related:
https://github.com/elasticsearch/elasticsearch/issues/2833

Leonardo Menezes
http://lmenezes.com

http://twitter.com/leonardomenezes

On Thu, Oct 31, 2013 at 9:24 PM, <rkar...@gmail.com <javascript:>> wrote:

Hi,
Hi,

I'll retry this with the latest master code.
I wrote down curl commands just to explain the issue. I am not directly
using curl.

I was wondering - why do you need to put a metadata block on a closed
index?
I don't need actually :slight_smile:
More than a year, I am working on an ES administration tool (Web based).
I encountered this issue while I am testing my gui.

On Monday, October 28, 2013 2:43:34 PM UTC+2, Boaz Leskes wrote:

Hi,

I can't reproduce your error on master. My guess is that it is because
the curl syntax misses a -d parameter on the end. This causes no body to be
sent

curl -XPUT "http://localhost:9200/test/_**settingshttp://localhost:9200/test/_settings"
-d'
{
"index": {
"blocks":{
"metadata":false
}
}
}'

I was wondering - why do you need to put a metadata block on a closed
index?

On Sunday, October 27, 2013 8:32:59 PM UTC+1, rkar...@gmail.com wrote:

Hi,

I am facing an issue related to the metadata blocking setting.
I told ES to disable the metadata changes for an index using update API
but don't know how to revert it back.

I tried reverting it back using the fallowing command while the index
in close state.

curl -XPUT 'http://127.0.0.1:9200/test1/_**settings http://127.0.0.1:9200/test1/_settings'

{
"index": {
"blocks":{
"metadata":false
}
}

}

Bu it returned:

{

  • error: ClusterBlockException[**blocked by: [FORBIDDEN/4/index
    closed];[FORBIDDEN/8/index write (api)];]
  • status: 403

}

Here is the gist:
https://gist.github.com/**rkarakaya/7186753https://gist.github.com/rkarakaya/7186753

I hope someone help me.

NOTE: I am using a few day old master branch of ES.

Thanks.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Leonardo Menezes) #6

that's what I did... even though I did't really appreciate this kind of "no
turning back" operations. seems dangerous.

Leonardo Menezes
http://lmenezes.com

http://twitter.com/leonardomenezes

On Thu, Oct 31, 2013 at 10:23 PM, rkarakaya@gmail.com wrote:

yes. it seems similar.

My workaround is :
Don't allow user to change this setting :slight_smile:

On Thursday, October 31, 2013 10:58:06 PM UTC+2, Leonardo Menezes wrote:

maybe this is related: https://github.com/*elasticsearch/elasticsearch/
*issues/2833 https://github.com/elasticsearch/elasticsearch/issues/2833

Leonardo Menezes
http://lmenezes.com

http://twitter.com/leonardomenezes

On Thu, Oct 31, 2013 at 9:24 PM, rkar...@gmail.com wrote:

Hi,
Hi,

I'll retry this with the latest master code.
I wrote down curl commands just to explain the issue. I am not directly
using curl.

I was wondering - why do you need to put a metadata block on a closed
index?
I don't need actually :slight_smile:
More than a year, I am working on an ES administration tool (Web based).
I encountered this issue while I am testing my gui.

On Monday, October 28, 2013 2:43:34 PM UTC+2, Boaz Leskes wrote:

Hi,

I can't reproduce your error on master. My guess is that it is because
the curl syntax misses a -d parameter on the end. This causes no body to be
sent

curl -XPUT "http://localhost:9200/test/_settingshttp://localhost:9200/test/_settings"
-d'
{
"index": {
"blocks":{
"metadata":false
}
}
}'

I was wondering - why do you need to put a metadata block on a closed
index?

On Sunday, October 27, 2013 8:32:59 PM UTC+1, rkar...@gmail.com wrote:

Hi,

I am facing an issue related to the metadata blocking setting.
I told ES to disable the metadata changes for an index using update
API but don't know how to revert it back.

I tried reverting it back using the fallowing command while the index
in close state.

curl -XPUT 'http://127.0.0.1:9200/test1/_****settings http://127.0.0.1:9200/test1/_settings'

{
"index": {
"blocks":{
"metadata":false
}
}

}

Bu it returned:

{

  • error: ClusterBlockException[blocked by: [FORBIDDEN/4/index
    closed];[FORBIDDEN/8/index write (api)];]
  • status: 403

}

Here is the gist:
https://gist.github.com/rkarakaya/7186753https://gist.github.com/rkarakaya/7186753

I hope someone help me.

NOTE: I am using a few day old master branch of ES.

Thanks.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@**googlegroups.com.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #7