Java 8 supports till which elasticsearch version?

Java 8 supports till which elasticsearch version?

We are currently using Java 8 and no plans to upgrade our application to java 11 in near future.
We are planning to upgrade our elasticsearch from 5.6.0 to 7.4 (first to 6.5.8).
So, trying to see if java 8 is supported for few more years. please help to confirm or point me to a doc which has this information.

Hi @Renuka

This might be what you are looking for.

Cheers
MiTschMR

Thanks. I've seen the document you have shared.

One other question, In end of life cycle document https://www.elastic.co/support/eol , I see that the maintained till for 7.4 is 7.5 . is it because there is no next major released yet and if released it will be supported until next two major versions

or 7.4 will be supported only till 7.5?