Support for Java 11


(Bittu Sarkar) #1

Support for Java 8 for commercial use will end in Jan 2019. For Java 9 and 10, it will end even before that because they are non-LTS versions. I read https://www.elastic.co/blog/elasticsearch-java-9-and-beyond but it does not talk about supporting Java 11. Do you have any plans of adding support for Java 11 before January 2019? And, which version of Elasticsearch would likely get that support?


Logstash and Java 11
(Christoph) #2

Hi @bsarkar

last week we switched our internal builds on master and 6.x to require Java 11. That means we are actively testing with this version on the new release branches. However, it is still not part of the official support matrix, but my guess it is will be added in a short timeframe since we are actively working towards it.

Although this is not a definitive "yes", I how it helps.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.