Java error

Ran into this while executing \bin\elasticsearch.bat, anyone encountered the same error??

Picked up _JAVA_OPTIONS: -Xmx512M -Xms256M
\Java\jre1.8.0_171\bin\java.exe" -cp "!ES_CLASSPATH!" "" "!ES_JVM_OPTIONS!" || echo jvm_options_parser_failed"`) was unexpected at this time.

What OS, what Elasticsearch version?

I am also facing the same issue.
Windows 10 64-bit
Elasticsearch 6.3.0

Same error for me as well.

now I am having this error. seriously why cant elastic stack make the installation way easier and allow users to not have to keep troubleshooting??

Picked up _JAVA_OPTIONS: -Xmx512M -Xms256M
Error: Could not find or load main class Picked
Caused by: java.lang.ClassNotFoundException: Picked

How did you install elasticsearch?

Did you follow this guide?

yes i did

How? CLI? GUI?
Which step did not work exactly?

every step worked until when i used
to run it and encounter the errors

Again, how did you install it?

i downloaded the file from and then used the GUI with default values to install. in other words, i followed the guide. what more information you need?

Thanks. This is helpful so we can investigate further.
We will update this when we have more information.

In the meantime you can may be download the zip version and run it manually?

Started working for me after updating the Java version from 1.8.0_161 to 1.8.0_171.
I tried by using zip version of Elasticsearch.

1 Like

Very good to know.

Hi were you able to resolve the error.I am also facing the same issue.Please let me know what did you do to get the error resolved.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.