Jvm_options_parser_failed ... jvm.options ... was unexpected at this time

I ran into this same problem that somebody else posted a year ago.

The solution that worked is the one from A_M. The one from forloop didn't work. As jasontedor pointed out, the brackets are the issue. So replacing "Program Files (x86)" with "Progra~2" avoids the brackets.

I can't believe that after a year this still hasn't been fixed and released. Everybody on Windows that follows the installation instructions should experience the same issue.

On an additional note, you run into this issue if you have Java 32-bit installed. Apparently, Elasticsearch determines the bitness of your machine by looking at the bitness of Java installed on your system. Now 32 bit Java is installed in the Program Files (x86) directory which has those brackets.

If you use 32 bit Java then the installer will run into other issues (X-pack and machine learning). So it's probably best to install Java 64 bit. Alternatively, in Elasticsearch.yml you can add set xpack.ml.enabled: false.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.