Not able to install Elasticsearch 6.7 - Windows 10

New to Elasticsearch, want to try it out and configure it on my workstation Windows 10.

Here is the value of JAVA_HOME :
C:\Program Files (x86)\Java\jre1.8.0_191

... and here is java -version
java version "1.8.0_191"
Java(TM) SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot(TM) Client VM (build 25.191-b12, mixed mode)

When I run the elasticsearch.bat
I get the following error:
\Java\jre1.8.0_191\bin\java.exe" -cp "!ES_CLASSPATH!" """` was unexpected at this time.

Please help.

Hi @elasticgirl,

could look like you have run into something similar to:

I think the trigger of the problem is the parenthesis in JAVA_HOME. A workaround might be to install a 64 bit version of java instead to avoid parenthesis in the path.

Actually, yes that worked. I uninstall java and the jdk. And re-installed making sure it was the 64bit version.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.