JDBC Input Error after upgrading to 7.10.0 on Windows

Hi All,

I updated my Windows DEV environment to 7.10.0 from 7.9.2 earlier today. When I try to run my existing Logstash configurations in 7.10.0 (which worked fine under 7.9.2) I see the following error:

[2020-11-27T12:06:12,605][ERROR][logstash.inputs.jdbc ][main][d0af23ae1e46c4686c19aa4f8968d5207dbc491cb54cb93401277b0cd6d68d82] Unable to connect to database. Tried 1 times {:error_message=>"Java::JavaLang::NoClassDefFoundError: javax/xml/bind/DatatypeConverter"}

This appears similar to an issue reported with an earlier version of Logstash a while back.

https://datamansamxiao.wordpress.com/2019/12/06/using-elastic-search-connect-to-sql-database-and-text-querying-by-kibana/

However, I've tried the workaround suggested there which was to copy the SQL driver into the logstash-core/lib/jars area, and supply just quotes for the jdbc_driver_library parameter on the configuration input, but it didn't make any difference in my case.

Anyone else encountered this?

Cheers,
Steve

2 Likes

Anybody else encountered this issue. Looks like I might have to switch back to 7.9.x if there's no workaround within 7.10 currently.

Cheers,
Steve

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.