JDBC River decimal problem


(Simon Madsen) #1

Hey everyone

i've just implemented a River pulling data from a database, and it is
working just fine, except one of my columns is a FLOAT(7,2) type, but when
it is imported into elasticsearch, the decimalpoint is deleted

Example: Fieldvalue: 999.99 ES-value: 99999

I know this isn't much information to go on, but have you heard of this
problem before?

Thanks in advance
Simon

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6c6f13c0-b0b1-4608-bb29-e8dea886b9ce%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #2

Parsing numbers depends on the locale.

Can you check if setting the "locale" parameter of the JDBC river makes any
difference?

I admit this is poorly documented.

Jörg

On Tue, Jul 29, 2014 at 4:12 PM, Simon Madsen <
simon.hammerholt.madsen@gmail.com> wrote:

Hey everyone

i've just implemented a River pulling data from a database, and it is
working just fine, except one of my columns is a FLOAT(7,2) type, but when
it is imported into elasticsearch, the decimalpoint is deleted

Example: Fieldvalue: 999.99 ES-value: 99999

I know this isn't much information to go on, but have you heard of this
problem before?

Thanks in advance
Simon

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/6c6f13c0-b0b1-4608-bb29-e8dea886b9ce%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/6c6f13c0-b0b1-4608-bb29-e8dea886b9ce%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoF%2Bb3OQ-Mf-o84BuqCEZh-dXxNn47xAuhgE9wZrKRWJBg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3