[ANN] JDBC river 1.0.0.1 released


(Jörg Prante) #1

Hi,

JDBC river plugin 1.0.0.1 for Elasticsearch 1.0.0 has been released.

Changes:

  • compiled against Elasticsearch 1.0.0
  • refactored some classes for preparing the move to a more robust data
    gathering plugin
  • improved JSON building when reading JSON out of a result column
  • possible to access river state (timestamp) as SQL parameter
  • reverted Collection to List in KeyValueStreamListener
  • some cleanups

Best,

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFrCUx6xB%3D40UTu6BgL8fKaQDrQ57ANexr569tfKVgGSg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tomislav Poljak) #2

Hi,
I've tried new/latest jdbc river plugin for elasticsearch 1.0.0 (with
the latest es v1.0.0) and simple river definition:

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"driver" : "com.mysql.jdbc.Driver",
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table"
},
"index" : {
"index" : "index_name",
"type" : "type_name"
}
}'

ended up importing data into index named 'jdbc' (instead 'index_name')
and type set in indexed docs was also 'jdbc' (instead of type_name)

Did something changed (completely) in how jdbc river is defined (I've
checked the docs didn't find anything) or is this a bug?

Tomislav

2014-02-13 1:37 GMT+01:00 joergprante@gmail.com joergprante@gmail.com:

Hi,

JDBC river plugin 1.0.0.1 for Elasticsearch 1.0.0 has been released.

https://github.com/jprante/elasticsearch-river-jdbc

Changes:

  • compiled against Elasticsearch 1.0.0
  • refactored some classes for preparing the move to a more robust data
    gathering plugin
  • improved JSON building when reading JSON out of a result column
  • possible to access river state (timestamp) as SQL parameter
  • reverted Collection to List in KeyValueStreamListener
  • some cleanups

Best,

Jörg

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFrCUx6xB%3D40UTu6BgL8fKaQDrQ57ANexr569tfKVgGSg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALuCJxgmZ%2BqWgNenAEuuo22R%2BhrXCHfXTzWyTL72Z4iwqZ962A%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Jörg Prante) #3

There is no index section any more.

Try

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table",
"index" : "index_name",
"type" : "type_name"
}
}'

Jörg

On Sun, Feb 16, 2014 at 7:28 PM, Tomislav Poljak tpoljak@gmail.com wrote:

Hi,
I've tried new/latest jdbc river plugin for elasticsearch 1.0.0 (with
the latest es v1.0.0) and simple river definition:

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"driver" : "com.mysql.jdbc.Driver",
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table"
},
"index" : {
"index" : "index_name",
"type" : "type_name"
}
}'

ended up importing data into index named 'jdbc' (instead 'index_name')
and type set in indexed docs was also 'jdbc' (instead of type_name)

Did something changed (completely) in how jdbc river is defined (I've
checked the docs didn't find anything) or is this a bug?

Tomislav

2014-02-13 1:37 GMT+01:00 joergprante@gmail.com joergprante@gmail.com:

Hi,

JDBC river plugin 1.0.0.1 for Elasticsearch 1.0.0 has been released.

https://github.com/jprante/elasticsearch-river-jdbc

Changes:

  • compiled against Elasticsearch 1.0.0
  • refactored some classes for preparing the move to a more robust data
    gathering plugin
  • improved JSON building when reading JSON out of a result column
  • possible to access river state (timestamp) as SQL parameter
  • reverted Collection to List in KeyValueStreamListener
  • some cleanups

Best,

Jörg

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFrCUx6xB%3D40UTu6BgL8fKaQDrQ57ANexr569tfKVgGSg%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALuCJxgmZ%2BqWgNenAEuuo22R%2BhrXCHfXTzWyTL72Z4iwqZ962A%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHw%2Be5GLBR2sho0VJZva7w_sTiY0Kvfe-w0UpqQ%2BMu6Qg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Tomislav Poljak) #4

Hi Jörg,
seems I've missed docs update. Works correctly without the 'index'
section, thanks!

Tomislav

2014-02-16 19:41 GMT+01:00 joergprante@gmail.com joergprante@gmail.com:

There is no index section any more.

Try

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table",
"index" : "index_name",
"type" : "type_name"
}
}'

Jörg

On Sun, Feb 16, 2014 at 7:28 PM, Tomislav Poljak tpoljak@gmail.com wrote:

Hi,
I've tried new/latest jdbc river plugin for elasticsearch 1.0.0 (with
the latest es v1.0.0) and simple river definition:

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"driver" : "com.mysql.jdbc.Driver",
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table"
},
"index" : {
"index" : "index_name",
"type" : "type_name"
}
}'

ended up importing data into index named 'jdbc' (instead 'index_name')
and type set in indexed docs was also 'jdbc' (instead of type_name)

Did something changed (completely) in how jdbc river is defined (I've
checked the docs didn't find anything) or is this a bug?

Tomislav

2014-02-13 1:37 GMT+01:00 joergprante@gmail.com joergprante@gmail.com:

Hi,

JDBC river plugin 1.0.0.1 for Elasticsearch 1.0.0 has been released.

https://github.com/jprante/elasticsearch-river-jdbc

Changes:

  • compiled against Elasticsearch 1.0.0
  • refactored some classes for preparing the move to a more robust data
    gathering plugin
  • improved JSON building when reading JSON out of a result column
  • possible to access river state (timestamp) as SQL parameter
  • reverted Collection to List in KeyValueStreamListener
  • some cleanups

Best,

Jörg

--
You received this message because you are subscribed to the Google
Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFrCUx6xB%3D40UTu6BgL8fKaQDrQ57ANexr569tfKVgGSg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALuCJxgmZ%2BqWgNenAEuuo22R%2BhrXCHfXTzWyTL72Z4iwqZ962A%40mail.gmail.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHw%2Be5GLBR2sho0VJZva7w_sTiY0Kvfe-w0UpqQ%2BMu6Qg%40mail.gmail.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALuCJxhe8M-Uym7m1%2BY_a4i7dhD2tBJ%3D2cCcwsirTwcFUMv6SQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(hari) #5

Jorg, how can I make this run hourly, I could not find an example in
Quickstart.

curl -XPUT "http://localhost:9200/_river/my_jdbc_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"url" : "jdbc:oracle:thin:@192.168.0.108:1521:PROD",
"user" : "wcs7dev",
"password" : "wcs7dev",
"sql" : "select * from catentry",
"index" : "catalog",
"type" : "products"
}
}'

On Sunday, February 16, 2014 12:41:22 PM UTC-6, Jörg Prante wrote:

There is no index section any more.

Try

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table",
"index" : "index_name",
"type" : "type_name"
}
}'

Jörg

On Sun, Feb 16, 2014 at 7:28 PM, Tomislav Poljak <tpo...@gmail.com<javascript:>

wrote:

Hi,
I've tried new/latest jdbc river plugin for elasticsearch 1.0.0 (with
the latest es v1.0.0) and simple river definition:

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"driver" : "com.mysql.jdbc.Driver",
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table"
},
"index" : {
"index" : "index_name",
"type" : "type_name"
}
}'

ended up importing data into index named 'jdbc' (instead 'index_name')
and type set in indexed docs was also 'jdbc' (instead of type_name)

Did something changed (completely) in how jdbc river is defined (I've
checked the docs didn't find anything) or is this a bug?

Tomislav

2014-02-13 1:37 GMT+01:00 joerg...@gmail.com <javascript:> <
joerg...@gmail.com <javascript:>>:

Hi,

JDBC river plugin 1.0.0.1 for Elasticsearch 1.0.0 has been released.

https://github.com/jprante/elasticsearch-river-jdbc

Changes:

  • compiled against Elasticsearch 1.0.0
  • refactored some classes for preparing the move to a more robust data
    gathering plugin
  • improved JSON building when reading JSON out of a result column
  • possible to access river state (timestamp) as SQL parameter
  • reverted Collection to List in KeyValueStreamListener
  • some cleanups

Best,

Jörg

--
You received this message because you are subscribed to the Google
Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit

https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFrCUx6xB%3D40UTu6BgL8fKaQDrQ57ANexr569tfKVgGSg%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALuCJxgmZ%2BqWgNenAEuuo22R%2BhrXCHfXTzWyTL72Z4iwqZ962A%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8f09e872-ba5e-464c-9dc2-24c57880f2e9%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(hari) #6

Alright I figured it out.
Adding something like this triggers it every 5 mins.
"schedule":"0 0/5 * * * ?"

On Monday, February 17, 2014 10:16:49 AM UTC-6, Hariharan Vadivelu wrote:

Jorg, how can I make this run hourly, I could not find an example in
Quickstart.

curl -XPUT "http://localhost:9200/_river/my_jdbc_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"url" : "jdbc:oracle:thin:@192.168.0.108:1521:PROD",
"user" : "wcs7dev",
"password" : "wcs7dev",
"sql" : "select * from catentry",
"index" : "catalog",
"type" : "products"
}
}'

On Sunday, February 16, 2014 12:41:22 PM UTC-6, Jörg Prante wrote:

There is no index section any more.

Try

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table",
"index" : "index_name",
"type" : "type_name"
}
}'

Jörg

On Sun, Feb 16, 2014 at 7:28 PM, Tomislav Poljak tpo...@gmail.comwrote:

Hi,
I've tried new/latest jdbc river plugin for elasticsearch 1.0.0 (with
the latest es v1.0.0) and simple river definition:

curl -XPUT "http://localhost:9200/_river/table_river/_meta" -d'{
"type" : "jdbc",
"jdbc" : {
"driver" : "com.mysql.jdbc.Driver",
"url" : "jdbc:mysql://host/db",
"user" : "x",
"password" : "y",
"sql" : "select * from table"
},
"index" : {
"index" : "index_name",
"type" : "type_name"
}
}'

ended up importing data into index named 'jdbc' (instead 'index_name')
and type set in indexed docs was also 'jdbc' (instead of type_name)

Did something changed (completely) in how jdbc river is defined (I've
checked the docs didn't find anything) or is this a bug?

Tomislav

2014-02-13 1:37 GMT+01:00 joerg...@gmail.com joerg...@gmail.com:

Hi,

JDBC river plugin 1.0.0.1 for Elasticsearch 1.0.0 has been released.

https://github.com/jprante/elasticsearch-river-jdbc

Changes:

  • compiled against Elasticsearch 1.0.0
  • refactored some classes for preparing the move to a more robust data
    gathering plugin
  • improved JSON building when reading JSON out of a result column
  • possible to access river state (timestamp) as SQL parameter
  • reverted Collection to List in KeyValueStreamListener
  • some cleanups

Best,

Jörg

--
You received this message because you are subscribed to the Google
Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit

https://groups.google.com/d/msgid/elasticsearch/CAKdsXoFrCUx6xB%3D40UTu6BgL8fKaQDrQ57ANexr569tfKVgGSg%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CALuCJxgmZ%2BqWgNenAEuuo22R%2BhrXCHfXTzWyTL72Z4iwqZ962A%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1e7d525e-4c67-408d-af0d-6a0db127403d%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #7