Junk indexes created automatically


(Govind Kothari) #1

Hi,

I can see that junk indexes are getting created in elasticsearch node. What
can be the possible reason ? I am sure its not an issue with my code.

Thanks,
Govind

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #2

Elasticsearch enables automatic index creation on by default, so you are
probably indexing documents to these junk indexes. Try disabling the
feature (action.auto_create_index) and see if the problem persists,

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/docs-index_.html#index-creation

Cheers,

Ivan

On Thu, Nov 7, 2013 at 2:31 PM, Govind Kothari govindkothari@gmail.comwrote:

Hi,

I can see that junk indexes are getting created in elasticsearch node.
What can be the possible reason ? I am sure its not an issue with my code.

Thanks,
Govind

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Lukáš Vlček) #3

You can also check es log. IIRC by default it logs about new index creation
and the reason behind it (api call or automatic).
Lukáš
Dne 7.11.2013 23:48 "Ivan Brusic" ivan@brusic.com napsal(a):

Elasticsearch enables automatic index creation on by default, so you are
probably indexing documents to these junk indexes. Try disabling the
feature (action.auto_create_index) and see if the problem persists,

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/docs-index_.html#index-creation

Cheers,

Ivan

On Thu, Nov 7, 2013 at 2:31 PM, Govind Kothari govindkothari@gmail.comwrote:

Hi,

I can see that junk indexes are getting created in elasticsearch node.
What can be the possible reason ? I am sure its not an issue with my code.

Thanks,
Govind

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4