K4.3 No display Field Formatters


(Jorge Ramirez) #1

Follow the instructions as indicated by the link Writing Custom Field Formatters , but in index options is not displayed . I also did the test to modify String, js nor the modifications made ​​are showed . Kibana service stopped and started again and neither showed . I appreciate the help you can give me the steps I should follow.


(Matt Bargar) #2

I'm not sure I understand the problem. Are you saying you tried to add a field formatter, but your change wasn't saved? Could you provide some additional details, like specific steps to reproduce the issue?


(Jorge Ramirez) #3

Following the https://www.elastic.co/blog/kibana-custom-field-formatters example, should show the Highlight option in Setting - > Control - > Format (string ) and do not. String.js also modify the file to show other labels and neither did . ( scr / ui / public / type ) . I do not know what happens.


(Jon Budzenski) #4

Are you running Kibana in dev mode? If not, once the script bundles have been generated any new changes won't be picked up. Running bin/kibana --dev when developing can make things easier, it will check for changes on refresh and generate new script bundles if necessary.


(system) #5