Kibana 4.6 won't let me add a new index pattern to import very basic json file

I have a very basic config file to import a json file into logstash and view in Kibana. Below

indent preformatted text by 4 spaces
input {
file {path => "/labs/dtf/logs/level1.json" }
filter {
json { source => "message"}
output {
elasticsearch {index => "lab-dtf-json"}
Ingestion went fine with no errors, so pipeline was started and file should be in Logstash.
But, when I go to Kibana 4.6 and "add new" index pattern of lab-*, I keep getting "unable to fetch mapping. Do you have indices matching the pattern?". Well, I would have one if it would let me add it, but what am I doing wrong???? I'm totally baffled!!
I go into Kopf to see if the index is there, and it is not.
I have spent days looking for a resolution but all I find are instructions which I have already tried, with no luck.
Anyone have any idea what I'm doing wrong? Maybe it's the time feild, but I have tried checking and unchecking all the boxes and nothing changes...

Sounds like you're having trouble getting the logstash pipeline to actually index into Elasticsearch, otherwise Kibana and Kopf would show the index. The index pattern creation in Kibana is just for reading data out of indexes that already exist in Elasticsearch.

I've moved your question over to the logstash group and hopefully someone from there will be able to help out.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.