Kibana 4 not recognizing the indice?


(Yu Watanabe) #1

Hello!

I would like to ask question regarding to kibana 4.

I got my elasticsearch and kibana installed on CentOS 6.

elasticsearch-1.5.0-1.noarch
kibana-4.0.1

However there seems to be a indice that kibana does not recognize
although it exists in elasticsearch.

[root@web elasticsearch]# curl localhost:9200/_cat/indices
yellow open logs 5 1 4894 0 1.3mb 1.3mb
yellow open kibana-int 5 1 4 0 49.7kb 49.7kb
green open personal 1 0 60 0 47.2kb 47.2kb <- This is the
target index
yellow open .kibana 1 1 4 0 23.5kb 23.5kb
yellow open household 5 1 200 0 226.8kb 226.8kb

But from the kibana interface, whenever I input "personal",
it says "Unable to fetch mapping. Do you have indices matching the pattern?"

Is there any setting that I can look at to overcome this issue?

Thanks,
Yu

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6aefb469-667e-4c62-a302-a42370d5d478%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Yu Watanabe) #2

household and logs were properly recognized by kibana.

On Wednesday, April 29, 2015 at 5:06:44 PM UTC+9, Yu Watanabe wrote:

Hello!

I would like to ask question regarding to kibana 4.

I got my elasticsearch and kibana installed on CentOS 6.

elasticsearch-1.5.0-1.noarch
kibana-4.0.1

However there seems to be a indice that kibana does not recognize
although it exists in elasticsearch.

[root@web elasticsearch]# curl localhost:9200/_cat/indices
yellow open logs 5 1 4894 0 1.3mb 1.3mb
yellow open kibana-int 5 1 4 0 49.7kb 49.7kb
green open personal 1 0 60 0 47.2kb 47.2kb <- This is the
target index
yellow open .kibana 1 1 4 0 23.5kb 23.5kb
yellow open household 5 1 200 0 226.8kb 226.8kb

But from the kibana interface, whenever I input "personal",
it says "Unable to fetch mapping. Do you have indices matching the
pattern?"

Is there any setting that I can look at to overcome this issue?

Thanks,
Yu

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2c62201e-4e70-4f9a-95f4-5f43e4d96077%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #3

Check that you have unchecked some checkboxes and that your Kibana dashboard settings looks like this http://david.pilato.fr/blog/images/elk-stations/settings-set-index.png http://david.pilato.fr/blog/images/elk-stations/settings-set-index.png

It should work fine.

--
David Pilato - Developer | Evangelist
elastic.co
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 29 avr. 2015 à 10:07, Yu Watanabe yu.w.tennis@gmail.com a écrit :

household and logs were properly recognized by kibana.

On Wednesday, April 29, 2015 at 5:06:44 PM UTC+9, Yu Watanabe wrote:
Hello!

I would like to ask question regarding to kibana 4.

I got my elasticsearch and kibana installed on CentOS 6.

elasticsearch-1.5.0-1.noarch
kibana-4.0.1

However there seems to be a indice that kibana does not recognize
although it exists in elasticsearch.

[root@web elasticsearch]# curl localhost:9200/_cat/indices
yellow open logs 5 1 4894 0 1.3mb 1.3mb
yellow open kibana-int 5 1 4 0 49.7kb 49.7kb
green open personal 1 0 60 0 47.2kb 47.2kb <- This is the target index
yellow open .kibana 1 1 4 0 23.5kb 23.5kb
yellow open household 5 1 200 0 226.8kb 226.8kb

But from the kibana interface, whenever I input "personal",
it says "Unable to fetch mapping. Do you have indices matching the pattern?"

Is there any setting that I can look at to overcome this issue?

Thanks,
Yu

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2c62201e-4e70-4f9a-95f4-5f43e4d96077%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/2c62201e-4e70-4f9a-95f4-5f43e4d96077%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2311B054-1C94-41E9-8427-2F0ABAAA7F7B%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Yu Watanabe) #4

Thank you for the reply.

But no use. Still does not show any signs for "personal" indice.

Thanks

On Wednesday, April 29, 2015 at 5:28:03 PM UTC+9, David Pilato wrote:

Check that you have unchecked some checkboxes and that your Kibana
dashboard settings looks like this
http://david.pilato.fr/blog/images/elk-stations/settings-set-index.png

It should work fine.

--
David Pilato - Developer | Evangelist
elastic.co http://elastic.co
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Le 29 avr. 2015 à 10:07, Yu Watanabe <yu.w....@gmail.com <javascript:>> a
écrit :

household and logs were properly recognized by kibana.

On Wednesday, April 29, 2015 at 5:06:44 PM UTC+9, Yu Watanabe wrote:

Hello!

I would like to ask question regarding to kibana 4.

I got my elasticsearch and kibana installed on CentOS 6.

elasticsearch-1.5.0-1.noarch
kibana-4.0.1

However there seems to be a indice that kibana does not recognize
although it exists in elasticsearch.

[root@web elasticsearch]# curl localhost:9200/_cat/indices
yellow open logs 5 1 4894 0 1.3mb 1.3mb
yellow open kibana-int 5 1 4 0 49.7kb 49.7kb
green open personal 1 0 60 0 47.2kb 47.2kb <- This is the
target index
yellow open .kibana 1 1 4 0 23.5kb 23.5kb
yellow open household 5 1 200 0 226.8kb 226.8kb

But from the kibana interface, whenever I input "personal",
it says "Unable to fetch mapping. Do you have indices matching the
pattern?"

Is there any setting that I can look at to overcome this issue?

Thanks,
Yu

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2c62201e-4e70-4f9a-95f4-5f43e4d96077%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2c62201e-4e70-4f9a-95f4-5f43e4d96077%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/46d69f0b-dd04-4ffa-a23f-cdb18f472c18%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Yu Watanabe) #5

I just experimentally updated the indice and now kibana 4 recognize the
indice.
It looks like some setting changed active after the update.

Strange but now it works...

On Wednesday, April 29, 2015 at 5:06:44 PM UTC+9, Yu Watanabe wrote:

Hello!

I would like to ask question regarding to kibana 4.

I got my elasticsearch and kibana installed on CentOS 6.

elasticsearch-1.5.0-1.noarch
kibana-4.0.1

However there seems to be a indice that kibana does not recognize
although it exists in elasticsearch.

[root@web elasticsearch]# curl localhost:9200/_cat/indices
yellow open logs 5 1 4894 0 1.3mb 1.3mb
yellow open kibana-int 5 1 4 0 49.7kb 49.7kb
green open personal 1 0 60 0 47.2kb 47.2kb <- This is the
target index
yellow open .kibana 1 1 4 0 23.5kb 23.5kb
yellow open household 5 1 200 0 226.8kb 226.8kb

But from the kibana interface, whenever I input "personal",
it says "Unable to fetch mapping. Do you have indices matching the
pattern?"

Is there any setting that I can look at to overcome this issue?

Thanks,
Yu

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a5690db2-d246-4a52-bd4b-4bfd39b86033%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #6