Kibana 5.0.0-snapshot requires Elasticsearch ^3.0.0?


(michele crudele) #1

I did setup a Kibana dev env for developing a plugin. Everything was working well until I pulled latest changes of kibana. Now when I try to start it I get the message

  log   [10:18:55.878] [error][status][plugin:elasticsearch] Status changed from yellow to red - This version of Kibana requires Elasticsearch ^3.0.0 on all nodes. I found the following incompatible nodes in your cluster: Elasticsearch v2.2.0 @ 172.17.0.2:9200 (172.17.0.2)

Where do I get elasticsearch v3? I even googled it but no success. Thanks.


(Tanya Bragin) #2

I believe you'll have to build it from source: https://github.com/elastic/elasticsearch#building-from-source


(Joe Fleming) #3

If you don't want to do your own build, you can also grab a snapshot build from the master branch.

You could instead use esvm and specify the master branch and it'll grab the latest snapshot for you. That's how we do development internally.

EDIT: Apparently the snapshot builds aren't actually published anywhere. We maintain a list of them for esvm to use, so the easiest way to get at them is just to use esvm. Otherwise, you're welcome to build from source too.


(Anu) #4

Hi , I tried to build using gradle but its really hard work to get it work behind proxy.
I was able to install esvm , but I am getting this error.

esvm https://github.com/elastic/elasticsearch.git 3.0.0
Oops Error: Unable to find a version for "https://github.com/elastic/elasticsearch.git" in "2.2.0", "2.1.2", "2.1.1", "2.1.0", "2.0.2", "2.0.1", "2.0.0", "2.0.0-rc1", "2.0.0-beta2", "2.0.0-beta1", "1.7.5", "1.7.4", "1.7.3", "1.7.2", "1.7.1", "1.7.0", "1.6.2", "1.6.1", "1.6.0", "1.5.2", "1.5.1", "1.5.0", "1.4.5", "1.4.4", "1.4.3", "1.4.2", "1.4.1", "1.4.0", "1.3.9", "1.3.8", "1.3.7", "1.3.6", "1.3.5", "1.3.4", "1.3.3", "1.3.2", "1.3.1", "1.3.0", "1.2.4", "1.2.3", "1.2.2", "1.2.1", "1.2.0", "1.1.2", "1.1.1", "1.1.0", "1.0.3", "1.0.2", "1.0.1", "1.0.0", "0.90.13", "0.90.12", "0.90.11", "0.90.10", "0.90.9", "0.90.8", "0.90.7", "0.90.6", "0.90.5", "0.90.4", "0.90.3", "0.90.2", "0.90.1", "0.90.0"

Is there any other way to get a snapshot ?

Thanks
Anu


(Joe Fleming) #5

3.0.0 isn't released yet, so you can't get at it by specifying the version. Instead, you'll want to use the branch flag.

-b, --branch install from a branch release

All work on 3.0 (now called 5.0) is happening on the master branch, so specifying that branch with esvm should be enough.

esvm -b master should do the trick.


(system) #6