Kibana 5.0 Blank Visualize Page


(Cjs6891) #1

Hi Guys,

I went to view/create visualizations and receive a blank page, prtscn attached.

steps I've taken:

  1. restart kibana, no luck...
  2. delete my logstash-* index pattern, stop & start kibana, recreate my logstash-* index pattern, no luck...

discovery, saved searches, & ad-hoc searching work fine


(Jon Budzenski) #2

Can you open your dev tools and share the console error? Is your current setup a recent upgrade from elasticsearch 2.x?


(Cjs6891) #3

fresh install, extracted from tar

commons.bundle.js?v=14438:37 PUT /elasticsearch/.kibana/_mapping/visualization 400 (Bad Request)(anonymous function) @ commons.bundle.js?v=14438:37sendReq @ commons.bundle.js?v=14438:37serverRequest @ commons.bundle.js?v=14438:37processQueue @ commons.bundle.js?v=14438:38(anonymous function) @ commons.bundle.js?v=14438:38$eval @ commons.bundle.js?v=14438:39$digest @ commons.bundle.js?v=14438:39(anonymous function) @ commons.bundle.js?v=14438:39completeOutstandingRequest @ commons.bundle.js?v=14438:36(anonymous function) @ commons.bundle.js?v=14438:36
commons.bundle.js?v=14438:38 Error: [illegal_argument_exception] mapper [version] cannot be changed from type [long] to [integer]
at respond (kibana.bundle.js?v=14438:14)
at checkRespForFailure (kibana.bundle.js?v=14438:14)
at kibana.bundle.js?v=14438:1
at processQueue (commons.bundle.js?v=14438:38)
at commons.bundle.js?v=14438:38
at Scope.$eval (commons.bundle.js?v=14438:39)
at Scope.$digest (commons.bundle.js?v=14438:39)
at Scope.$apply (commons.bundle.js?v=14438:39)
at done (commons.bundle.js?v=14438:37)
at completeRequest (commons.bundle.js?v=14438:37)


(Cjs6891) #4

fixed, I ran

"curl -XDELETE http://localhost:9200/.kibana"


(Fathi Rida) #5

Thank You @cjs6891


(system) #6