Kibana 5.1.2 Babel 5 option ERROR when starting Kibana


(John Mc Afee) #1

Hello,

I have a local VM that is using nodejs v6.9.4 and npm 3.10.10 on a Centos 6.5 platform.
I cloned the Kibana 5.1.2 software from the github repository. When I attempt to start the Kibana application, I get the following error:
[root@mydev bin]# ./kibana
/opt/kibana/node_modules/babel-register/node_modules/babel-core/lib/transformation/file/logger.js:41
throw new Constructor(this._buildMessage(msg));
^

ReferenceError: [BABEL] /opt/kibana/src/cli/cli.js: Using removed Babel 5 option: base.stage - Check out the corresponding stage-x presets http://babeljs.io/docs/plugins/#presets
at Logger.error (/opt/kibana/node_modules/babel-register/node_modules/babel-core/lib/transformation/file/logger.js:41:11)
at OptionManager.mergeOptions (/opt/kibana/node_modules/babel-register/node_modules/babel-core/lib/transformation/file/options/option-manager.js:216:20)
at OptionManager.init (/opt/kibana/node_modules/babel-register/node_modules/babel-core/lib/transformation/file/options/option-manager.js:374:12)
at File.initOptions (/opt/kibana/node_modules/babel-register/node_modules/babel-core/lib/transformation/file/index.js:216:65)
at new File (/opt/kibana/node_modules/babel-register/node_modules/babel-core/lib/transformation/file/index.js:139:24)
at Pipeline.transform (/opt/kibana/node_modules/babel-register/node_modules/babel-core/lib/transformation/pipeline.js:46:16)
at Object.transformFileSync (/opt/kibana/node_modules/babel-register/node_modules/babel-core/lib/api/node.js:138:10)
at compile (/opt/kibana/node_modules/babel-register/lib/node.js:118:20)
at loader (/opt/kibana/node_modules/babel-register/lib/node.js:144:14)
at Object.require.extensions.(anonymous function) [as .js] (/opt/kibana/node_modules/babel-register/lib/node.js:154:7)

Please let me know if I have not provided enough information to help me resolve my problem. Thank you!


(Jon Budzenski) #2

Can you share the output of npm ls --depth=0 | grep babel? Kibana uses babel 5, and it sounds like babel 6 may be running instead. If this the case, re-installing node modules should help.


(John Mc Afee) #3

Hi, below is the output from running the command. I had to cut a lot because of the 6000 character limit. Hopefully, this will help though.

[root@mydev kibana]# npm ls --depth=0 | grep babel
├── UNMET DEPENDENCY babel@6.5.2
├── babel-code-frame@6.20.0 extraneous
├── UNMET DEPENDENCY babel-core@6.21.0
├── babel-generator@6.21.0 extraneous
├── babel-helpers@6.16.0 extraneous
├── UNMET DEPENDENCY babel-loader@6.2.10
├── babel-register@6.18.0 extraneous
├── UNMET DEPENDENCY babel-runtime@6.20.0
npm ERR! missing: @bigfunger/decompress-zip@0.2.0-stripfix3, required by kibana@5.1.2
npm ERR! missing: @bigfunger/jsondiffpatch@0.1.38-webpack, required by kibana@5.1.2
npm ERR! missing: @elastic/datemath@2.3.0, required by kibana@5.1.2
npm ERR! missing: @elastic/kibana-ui-framework@0.0.13, required by kibana@5.1.2
npm ERR! missing: @spalger/filesaver@1.1.2, required by kibana@5.1.2
npm ERR! missing: @spalger/leaflet-draw@0.2.3, required by kibana@5.1.2
npm ERR! missing: @spalger/leaflet-heat@0.1.3, required by kibana@5.1.2
npm ERR! missing: @spalger/numeral@^2.2.1, required by kibana@5.1.2
npm ERR! missing: @spalger/test-subj-selector@0.2.1, required by kibana@5.1.2
npm ERR! missing: @spalger/ui-ace@0.2.3, required by kibana@5.1.2
npm ERR! missing: JSONStream@1.3.0, required by kibana@5.1.2
npm ERR! missing: angular@1.6.1, required by kibana@5.1.2
npm ERR! missing: angular-bootstrap-colorpicker@3.0.25, required by kibana@5.1.2
npm ERR! missing: angular-elastic@2.5.1, required by kibana@5.1.2
npm ERR! missing: angular-route@1.6.1, required by kibana@5.1.2
npm ERR! missing: angular-sanitize@1.6.1, required by kibana@5.1.2
npm ERR! missing: ansicolors@0.3.2, required by kibana@5.1.2
npm ERR! missing: autoprefixer@6.6.1, required by kibana@5.1.2
npm ERR! missing: autoprefixer-loader@3.2.0, required by kibana@5.1.2
npm ERR! missing: babel@6.5.2, required by kibana@5.1.2
npm ERR! missing: babel-core@6.21.0, required by kibana@5.1.2
npm ERR! missing: babel-loader@6.2.10, required by kibana@5.1.2
npm ERR! missing: babel-runtime@6.20.0, required by kibana@5.1.2
npm ERR! missing: bluebird@3.4.7, required by kibana@5.1.2
npm ERR! missing: body-parser@1.15.2, required by kibana@5.1.2
npm ERR! missing: boom@4.2.0, required by kibana@5.1.2
npm ERR! missing: brace@0.9.1, required by kibana@5.1.2
npm ERR! missing: bunyan@1.8.5, required by kibana@5.1.2
npm ERR! missing: check-hash@1.0.1, required by kibana@5.1.2
npm ERR! missing: commander@2.9.0, required by kibana@5.1.2
npm ERR! missing: css-loader@0.26.1, required by kibana@5.1.2
npm ERR! missing: d3@4.4.1, required by kibana@5.1.2
npm ERR! missing: d3-cloud@1.2.1, required by kibana@5.1.2
npm ERR! missing: dragula@3.7.2, required by kibana@5.1.2
npm ERR! missing: elasticsearch@12.1.3, required by kibana@5.1.2
npm ERR! missing: elasticsearch-browser@12.1.3, required by kibana@5.1.2
npm ERR! missing: encode-uri-query@1.0.1, required by kibana@5.1.2
npm ERR! missing: even-better@7.0.2, required by kibana@5.1.2
npm ERR! missing: expiry-js@0.1.7, required by kibana@5.1.2
npm ERR! missing: exports-loader@0.6.3, required by kibana@5.1.2
npm ERR! missing: expose-loader@0.7.1, required by kibana@5.1.2
npm ERR! missing: extract-text-webpack-plugin@1.0.1, required by kibana@5.1.2
npm ERR! missing: file-loader@0.9.0, required by kibana@5.1.2
npm ERR! missing: font-awesome@4.7.0, required by kibana@5.1.2
npm ERR! missing: glob@7.1.1, required by kibana@5.1.2
npm ERR! missing: glob-all@3.1.0, required by kibana@5.1.2
npm ERR! missing: validate-npm-package-name@2.2.2, required by kibana@5.1.2
npm ERR! missing: vision@4.1.1, required by kibana@5.1.2
npm ERR! missing: webpack@1.14.0, required by kibana@5.1.2
npm ERR! missing: webpack-directory-name-as-main@1.0.0, required by kibana@5.1.2
npm ERR! missing: whatwg-fetch@2.0.1, required by kibana@5.1.2
npm ERR! missing: wreck@10.0.0, required by kibana@5.1.2
npm ERR! extraneous: ansi-regex@2.0.0 /opt/kibana/node_modules/ansi-regex
npm ERR! extraneous: ansi-styles@2.2.1 /opt/kibana/node_modules/ansi-styles
npm ERR! extraneous: babel-code-frame@6.20.0 /opt/kibana/node_modules/babel-code-frame
npm ERR! extraneous: babel-generator@6.21.0 /opt/kibana/node_modules/babel-generator
npm ERR! extraneous: babel-helpers@6.16.0 /opt/kibana/node_modules/babel-helpers
npm ERR! extraneous: babel-register@6.18.0 /opt/kibana/node_modules/babel-register
npm ERR! invalid: lodash@3.10.1 /opt/kibana/node_modules/lodash


(Jon Budzenski) #4

It does look like babel 6 is being used. Can you try removing it and re-installing babel 5 instead?


(John Mc Afee) #5

Hello,

I figured you were going to say that :slight_smile:
I am not sure how to do that. But I will give it a try!
Thanks!


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.