Kibana 6.1.0. and newer starts with error

Hi Tim

There is no issue with permissions . I always run the install scripts from an admin account.

There is a difference between the contents of the optimize on a good and a bad installation.

On a working 6.1.1 installation with x-pack , i have 9.124.192 bytes in .cache and 38.254.227 bytes in bundles.

Can't someone look into what was changed in 6.1.0 in regards to compile/optimize step. 6.0.1 was the last good working version.


And just so we're ruling out the possibility of permissions, this admin account is the same user account that the service script uses to launch Kibana, correct?

There are a few team members discussing the issue in a backchannel. @Marius_Dragomir wants me to say he'll be back tomorrow and is going to look into the uploaded optimize folder that @Mojster provided.


Good news. Looks like something related to the startup directory logic.


Hi Viorel_Florian

Try this exactly as written.

Launch a new command prompt in admin mode.
cd c:\elastic\kibana <<< or whatever your kibana install directory is
rd optimize /s /q
When kibana is running , connect with browser to http://localhost:5601

If that doesnt work please have a look at optimize directory. How many bytes in .cache and in bundles ?


Tried it and still the same result
Optimize dir stats:
.cache - 5,842,526 bytes in 1,403 file(s), in 3 directories
bundles - 14,441,444 bytes in 55 file(s), in 7 directories


Just confirming the same issue with a clean install of Kibana 6.1.0 on Windows 2008 R2. No plugins involved, no X-Pack either. Tried all steps described in posts above to no avail.

Uncaught TypeError: (0 , _reactcss.handleHover) is not a function (http://#erver#:5601/bundles/kibana.bundle.js?v=16350:67)
Version: 6.1.1
Build: 16350
Error: Uncaught TypeError: (0 , _reactcss.handleHover) is not a function (http://#SERVER#:5601/bundles/kibana.bundle.js?v=16350:67)
at window.onerror (http://#SERVERS#:5601/bundles/commons.bundle.js?v=16350:45:8728)


Hi Kim, great to see that the issue can be detangled a bit further. Can you clarify what you mean by "startup directory logic"?

Hi Tim

Try this to reproduce on windows.

install 6.1.1 into c:\elastic\kibana
install x-pack
cd c:\elastic\kibana
rd optimize /s /q
and then this command

This is consistent on my machine to reproduce the error.

I get 9.124.192 in cache and 34.421.296 in bundles.


1 Like


I don't sure, but I think it is too long time between 'Optimizing and caching bundles' and 'Optimization of bundles for graph' records in the log (about 8 minutes):

c:\prg\logstash\kibana\kibana-6.1.1-windows-x86_64>rd optimize /s /q

  log   [08:35:19.538] [info][optimize] Optimizing and caching bundles for graph, monitoring, ml, apm, kibana, stateSessionStorageRedirect, timelion, login, logout, dashboardViewer and status_page. This may take a few minutes
  log   [08:43:08.779] [info][optimize] Optimization of bundles for graph, monitoring, ml, apm, kibana, stateSessionStorageRedirect, timelion, login, logout, dashboardViewer and status_page complete in 469.24 seconds
  log   [08:43:08.865] [info][status][plugin:kibana@6.1.1] Status changed from uninitialized to green - Ready
  log   [08:43:08.933] [info][status][plugin:elasticsearch@6.1.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch

I installed Kibana and Elasticsearch yesterday evening. It is my first installation of Kibana. I downloaded zip and this is my directories structure:

Removing of 'optimize' directory does not work for me, error message remains:

Please help me.


Did you run Kibana prior to moving it to the new folder? Just want to check when the new cache folder was created.
My hunch is that it has something to do with the cache generating absolute paths and the move messing with them, but I haven't found anything to confirm this.

I keep trying to reproduce this and can't manage to do it.
I followed @Kim-Kruse-Hansen 's steps for the x-pack one and it seems to work just fine.
Also, if I try to run it with @Mojster 's optimize folder, Kibana triggers another optimization when starting and it works just fine after that.


Same thing for x-pack

start a new command prompt in admin mode
create c:\elastic\kibana
robocopy from c:\elastic\install\kibana-6.1.1 to c:\elastic\kibana
********change directory to c:\elastic\kibana **********
run bin\kibana-plugin install x-pack
wait for it to launch on 5601
connect wit browser to verify that it works
shut it down
and then launch Kibana Service
and again
connect with browser to verify that it works

A few questions about this:

  1. Did you already start Kibana in this folder previously to copying it? c:\elastic\install\kibana-6.1.1
  2. By Kibana Service do you mean the service created by WIndows Service Wrapper?
  3. When it fails for you, did it work when starting it manually from bin/kibana or did it fail just like when starting it with the service?

I think there are should be some rules, when to build optimization folder.
Because, if I used one from previous version, it always started to rebuild.
But if I run my Kibana with WSW and after that manually on powershell id did not start a new optimization.

I fixed my WSW. There is also another alternative with NSSM. But it would be nice for Kibana to include a service installer like Eleastic Search or Beats.

Can you sum up exactly what you did to fix it and what you changed in your setup? This will help the other users as well. And yes, we are NSSM for Kibana in our automated tests, didn't have any problems with it up until now.
There is work in progress to create a service installer for Kibana, from the .msi package, but it's currently blocked by a change in the Kibana platform that will reduce the number of files in the package significantly.

My previous WSW config was:

  <name>Kibana (kibana-service)</name>
  <description>Kibana Windows Service</description>

and I changed it to:

 <name>Kibana (kibana-service)</name>
 <description>Kibana Windows Service</description>

After reinstalling the service you must manually remove the optimization folder or it won't rebuild from itself.

No I download the files and extract to c:\elastic\install\kibana-6.1.1. I never launch anything from that directory.


I use the NSSM utility to run Kibana as a Service.

Once it fails , I have to remove the optimize folder and let it rebuild on a new launch of bin\kibana.bat


Is there any progress/update on this case?
I tried starting kibana from CLI and as a service (using nssm), both with the original and recreated "optimize" folder with the same result.
Anyone have any advice?

I am also having this problem. I installed Version: 6.1.2
Build: 16363 on Windows 10. I tried removing the "optimization" folder but still receive the same error below. I checked folder permissions as well. Any assistance would be greatly appreciated.

Error: TypeError: _reactcss.handleHover is not a function (http://localhost:5601/bundles/kibana.bundle.js?v=16363:67)

Hi, same issue here. Tried with 6.1.1 and 6.1.2. The above workaround does not work.


I'm seeing this too (6.1.1 and now 6.2.1) and it seems to be an install-time (bundle build) rather than runtime issue.

The above workarounds have not worked for me. I always run from the install directory using "bin\kibana.bat" as described. We're using X-Pack and it has installed without complaint.

I and another member of the team made fresh installs of 6.1.1 a couple of weeks ago on our dev machines by the same process - his Kibana works, mine doesn't, we install and run the same way. A copy of his Kibana directory copied over next to my own does work (without an optimize run at startup). If I delete "my" optimize directory and allow it to be rebuilt, it fails - with the same invocation steps, plugins etc. I've tried diff'ing the optimize directories but there are too many differences to evaluate. Is there a way perhaps to debug the bundle build process? I found in the code reference to config fields optimize.enabled and optimize.useBundleCache but setting either/both of these to false leads to other page load failures.

Another data point: only /app/kibana seems affected (here). I can access (by typing - no navigation panel appears when the error does) /app/timelion, /app/ml, /app/apm and /app/monitoring.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.