6.2.0 starts with error


The bug that was present in Kibana 6.1.x is also present in 6.2.0 , albeit in a slightly different way,.

This time it is present like this

Looks like something went wrong. Refreshing may do the trick.

Go back Clear your session
Fatal Error
Uncaught TypeError: ace.require is not a function (http://localhost:5601/bundles/kibana.bundle.js?v=16562:1)
Version: 6.2.0
Build: 16562
Error: Uncaught TypeError: ace.require is not a function (http://localhost:5601/bundles/kibana.bundle.js?v=16562:1)
at window.onerror (http://localhost:5601/bundles/commons.bundle.js?v=16562:11:495755)

I will try to find a workaround again.


Hey there. Sorry you're running into trouble. When you say you ran into it before, can you let us know whether this was a issue you already reported (or saw in our issues list)? Offhand, my guess is there's some issue with the Ace editor we're using and the compile itself. Anything weird you have setup or any more information you can give? Assume you saw this on the open source version?


This is my first attempt at deploying an Elastic Stack and I am seeing the same error message when I open the Kibana homepage.

In setting up my deployment, I followed the instructions here:

Can you please advise?

Many thanks,

Hi @Kim-Kruse-Hansen,

Did you change or modify in any Elastic Stack plugins ?

Hi @paulp1,

If you have installed X-pack then following instruction you have to follow:

In this Elastic Stack 6.x version doesn't provide default username and password like elasstic and changeme if you have to see your Elastic Stack Default x-pack passwords then you used following command:

elasticsearch/bin/x-pack/setup-passwords auto -u "http://elasticsearch_IP:9200"

After this You have to change in your kibana.yml file
elasticsearch.username: elastic-username
elassticsearch.password: elastic-password

Thanks & Regards,

Hi David,

The error is very similar to this

My old workaround still works , you have to be very careful from where you launch kibana and its working directory.


I get this error "Uncaught TypeError: ace.require is not a function" as soon as I install x-pack in Kibana v6.2.2 as well as v6.1.1 on a windows 10 machine.

I had the same issue when I used a lowercase driverletter d:\app\kibana\kibana.bat (within nssm)
when I change it to the correct case, the optimize step works (after a clean unzip), and the error is gone.


I'm giving the correct case while executing kibana.exe, but still observing the error:
Uncaught TypeError: ace.require is not a function (http://localhost:5601/bundles/kibana.bundle.js?v=16573:22

P.S.: I observed that on Win7 Home edition, kibana worked; but failed on Win7 ultimate. Is Elastic search/Kibana does not support to specific OS edition?

A S Vyawahare

This is a very similar issue to Kibana 6.1.0. and newer starts with error
I tried starting kibana version 6.2.3 (with x-pack installed) as a service, manually unsuccessfully, both times making sure the working directory is kibana_home (d:\ELK\apps\kibana-6.2.3-windows-x86_64) not the bin directory. I also removed the "optimize" directory without success.

I have same problem.
Windows 8.1 Enterprise
Java 1.8.0_162
Elastic + Kibana: 6.2.3

I have followed video tutorial and stack in this error:
Uncaught TypeError: ace.require is not a function (http://localhost:5601/bundles/kibana.bundle.js?v=16562:12)

Is it a way to properly and successfully install elastic + kibana under windows ?

Any word on a workaround?

I have the same issue, is there a fix/workaround for this?

I have tried on
Windows 10/Windows Server 2016
Java 1.8.0_161
Elastic (via MSI) + Kibana: 6.2.3

I was using the vanilla install following the elastic instructions

Maybe I figured this out. I think you have to run this from PowerShell not the command line. At least on my Windows 2016 Server, it wouldn't work until I used PowerShell to launch it.

My guess would be that the optimize is creating paths that are too deep for the standard command prompt to handle.

1 Like

FYI - this solution is correct.
Plugin activity performed in Kibana on Windows must be done in PowerShell, not cmd

Thanks mlashbro

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.