Kibana 6.2.2 login fails


(Jim) #1

On logging into kibana I get:
Uncaught TypeError: ace.require is not a function (http://localhost:5601/bundles/kibana.bundle.js?v=16588:1)
My OS is windows 10 but I did not use the .msi. I just unzipped elasticsearch and kibana into c:\opt.
I have installed elasticsearch 6.2.2 and added x-pack.
I created the keystore and set the passwords for elastic, kibana, and logstash.
I added x-pack to kibana.
I set the elasticsearch.username and password in the kibana.yml file.
I started kibana from the root directory c:\opt\kibana-6.2.2-windows-x86_64>.\bin\kibana.
The server starts fine, but when open a browser to localhost:5601, I get a nice styled login page. When I log in I get the error.
I see there was a report of a similar error for release 6.2.1.
I have tried the ideas suggested there (remove kibana and add it back, and clear the /optimize directory) but no luck.


[SOLVED] X-Pack 6.2 install Fatal Error: ace.require is not a function
(kulkarni) #2

Can you please paste the error which you got with screenshots and logs as well? also the report of the similar error for 6.2.1 , it would help us debug further ...

When I looked up github, I found a similar issue which is still open: https://github.com/elastic/windows-installers/issues/166

Thanks
Rashmi


(VISHNU) #3

The X-Pack need a licensing. Whether the proper licensing is added? I also faced the issue. But got a free one year license and added to the elastic search and now its working fine!


(kulkarni) #4

Thanks for getting back with the resolution which worked for u.

Cheers
Rashmi


(Jim) #5

Uncaught TypeError: ace.require is not a function (http://localhost:5601/bundles/kibana.bundle.js?v=16588:1)
Version: 6.2.2
Build: 16588
Error: Uncaught TypeError: ace.require is not a function (http://localhost:5601/bundles/kibana.bundle.js?v=16588:1)
at window.onerror (http://localhost:5601/bundles/commons.bundle.js?v=16588:11:499579)


(Jim) #6

I tried to upload a log file, but only image files are allowed. This looks like the relevant bit:
[2018-03-09T09:49:26,588][ERROR][o.e.b.Bootstrap ] Exception
java.lang.IllegalArgumentException: unknown setting [xpack.license.self_generated.type] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:346) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:310) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:284) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:134) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.node.Node.(Node.java:331) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.node.Node.(Node.java:246) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:213) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:323) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.2.2.jar:6.2.2]
at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85) [elasticsearch-6.2.2.jar:6.2.2]
Suppressed: java.lang.IllegalArgumentException: unknown secure setting [bootstrap.password] please check that any required plugins are installed, or check the breaking changes documentation for removed settings
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:346) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:310) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:284) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:134) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.node.Node.(Node.java:331) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.node.Node.(Node.java:246) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:213) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:213) ~[elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:323) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:124) [elasticsearch-cli-6.2.2.jar:6.2.2]
at org.elasticsearch.cli.Command.main(Command.java:90) [elasticsearch-cli-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) [elasticsearch-6.2.2.jar:6.2.2]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:85) [elasticsearch-6.2.2.jar:6.2.2]


(Jim) #7

It looks like x-pack licensing, as VISHNU says. Your instructions don't mention this though.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.