No x-pack: Login is currently disabled. Administrators should consult the Kibana logs for more details


(shree) #1

Hi,

I have installed 6.3.2 elasticsearch and kibana on my vm when I tried to open kibana it's showing the below error.
Since I referred with the same error in this forum people say it's because of x-pack but I didn't install x-pack at all I don't know how to solve it.

Please help.

Kibana error:
kibana.service - Kibana

Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: enabled)

Active: **active (running)** since Thu 2018-08-09 08:05:07 UTC; 28s ago

Main PID: 10388 (node)

CGroup: /system.slice/kibana.service

└─10388 /usr/share/kibana/bin/../node/bin/node --no-warnings /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml

Aug 09 08:05:25 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:25Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"Unable to revive connection: http:/

/192.168.56.101:9200/"}

Aug 09 08:05:25 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:25Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"No living connections"}

Aug 09 08:05:28 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:28Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"Unable to revive connection: http:/

/192.168.56.101:9200/"}

Aug 09 08:05:28 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:28Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"No living connections"}

Aug 09 08:05:30 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:30Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"Unable to revive connection: http:/

/192.168.56.101:9200/"}

Aug 09 08:05:30 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:30Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"No living connections"}

Aug 09 08:05:33 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:33Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"Unable to revive connection: http:/

/192.168.56.101:9200/"}

Aug 09 08:05:33 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:33Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"No living connections"}

Aug 09 08:05:35 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:35Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"Unable to revive connection: http:/

/192.168.56.101:9200/"}

Aug 09 08:05:35 localhost.localdomain kibana[10388]: {"type":"log","@timestamp":"2018-08-09T08:05:35Z","tags":["warning","elasticsearch","admin"],"pid":10388,"message":"No living connections"}

(Frederic Leger) #2

@Shree seems that there is no elasticsearch backend reachable ?

Unable to revive connection: http://192.168.56.101:9200/"

(Frederic Leger) #3

But that being said i really don't understand the changes going on in the licensing of xpack right now and how this is badly affect the product.

From what i'm currently trying for one of my customer, after a fresh install on new instances on digital ocean, the kibana UI is displaying this message : 'Login is currently disabled'.

X-pack is disabled on every ES nodes in the others instances and it seems the only way to bypass that (other than buying a license ...) is to set xpack.security.enabled: false in kibana.yaml.

The drawback is that this take minutes in optimizing and make my instance reach 48 of load !!!

Aug  9 10:22:52 kibana kibana[18389]: {"type":"log","@timestamp":"2018-08-09T10:22:52Z","tags":["info","optimize"],"pid":18389,"message":"Optimization of bundles for ml, stateSessionStorageRedirect, status_page, timelion, graph, monitoring, dashboardViewer, apm and kibana complete in 889.63 seconds"}

I would rather think that the default should be to have it disabled and enable it when you do install xpack (which i can only strongly suggest for production servers).

If i remember well, long time ago elastic was saying that they were focused on making just work right away. with this change it's not anymore the case AMHA ...


(Rijin) #4

Add these lines in elasticsearch.yml as last lines

xpack.security.enabled: false
xpack.monitoring.enabled: false
xpack.graph.enabled: false
xpack.watcher.enabled: false
xpack.reporting.enabled: false


(Rijin) #5

in 6.3.2 xpack is available inside elasticsearch .

If you are installing elasticsearch , xpack is also installing


(shree) #6

hi, thanks for the reply,

But I'm still getting this error.

root@localhost:~# sudo service kibana status

sudo: unable to resolve host localhost.localdomain

**●** kibana.service - Kibana

Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: enabled)

Active: **active (running)** since Thu 2018-08-09 14:58:19 UTC; 3min 17s ago

Main PID: 11618 (node)

CGroup: /system.slice/kibana.service

└─11618 /usr/share/kibana/bin/../node/bin/node --no-warnings /usr/share/kibana/bin/../src/cli -c /etc/kibana/kibana.yml

Aug 09 15:01:32 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:32Z","tags":["warning","elasticsearch","data"],"pid":11618,"message

":"No living connections"}

Aug 09 15:01:32 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:32Z","tags":["license","warning","xpack"],"pid":11618,"message":"Li

cense information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. Error: No Living connections"}

Aug 09 15:01:33 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:33Z","tags":["warning","elasticsearch","admin"],"pid":11618,"messag

e":"Unable to revive connection: http://192.168.56.101:9200/"}

Aug 09 15:01:33 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:33Z","tags":["warning","elasticsearch","admin"],"pid":11618,"messag

e":"No living connections"}

Aug 09 15:01:35 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:35Z","tags":["warning","elasticsearch","admin"],"pid":11618,"messag

e":"Unable to revive connection: http://192.168.56.101:9200/"}

Aug 09 15:01:35 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:35Z","tags":["warning","elasticsearch","admin"],"pid":11618,"messag

e":"No living connections"}

Aug 09 15:01:35 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:35Z","tags":["warning","elasticsearch","admin"],"pid":11618,"messag

e":"Unable to revive connection: http://192.168.56.101:9200/"}

Aug 09 15:01:35 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:35Z","tags":["warning","elasticsearch","admin"],"pid":11618,"messag

e":"No living connections"}

Aug 09 15:01:36 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:36Z","tags":["warning","elasticsearch","admin"],"pid":11618,"messag

e":"Unable to revive connection: http://192.168.56.101:9200/"}

Aug 09 15:01:36 localhost.localdomain kibana[11618]: {"type":"log","@timestamp":"2018-08-09T15:01:36Z","tags":["warning","elasticsearch","admin"],"pid":11618,"messag

e":"No living connections"}

(Rijin) #7

What is the output of http://192.168.56.101:9200/ from browser ?


(Frederic Leger) #8

yes sure.

my point was more why this isn't working right away after install and why you have to add these lines ?
i would say this should be the default setting (and it was before 6.3 right ?)


(Rijin) #9

Did you indexed some data in elasticsearch ?

OR did you trying to use the previous indexes in current installation ?

How you are running elasticsearch ?

./bine/elasticsearch or systemctl start elasticsearch ?

We need to confirm the status of elasticsearch


(Rijin) #10

These lines are using for disabling the Xpack modules. If the issue is raising by any authentication problem , these lines will disable the login . You can login to kibana without any username and password.


(Frederic Leger) #11
  • ubuntu 16.04 packages from ES repos installed like mentionned in the docs and started with service elasticsearch start
  • No data injected
  • just fresh install on DigitalOcean for testing purposes

(Rijin) #12

Did you enabled the 30 day trial license through kibana ( Management Menu ) ?

That is the another chance to enabling xpack license .


(Frederic Leger) #13

nope


(Frederic Leger) #14

but seems that in 6.4 it's enabled by default check How xpack.license.self_generated.type: basic setting is really working?


(Rijin) #15

But authentication in not enabled in default .


(Frederic Leger) #16

that is not true anymore dude


(Rijin) #17

You are talking about the license . I am talking the security function in Xpack .

We have to enable it .


(Rijin) #18

Check this Link : https://www.elastic.co/guide/en/elasticsearch/reference/current/security-settings.html

General security settingsedit

xpack.security.enabled

Set to true to enable X-Pack security on the node.

If set to false , which is the default value for basic and trial licenses


(system) #19

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.